Skip to content

← Actionable
Medium, CVSS 4.7amended

Cross-site Scripting Vulnerability on Data Import

CVE-2024-23633GHSA-fq23-g58m-799r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (label-studio 1.10.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.7 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N
EPSS
  • CVE-2024-23633: 0.59% estimated exploitation activity in the next 30 days; percentile 48.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Introduction This write-up describes a vulnerability found in Label Studio, a popular open source data labeling tool. The vulnerability affects all versions of Label Studio prior to 1.10.1 and was tested on version 1.9.2.post0. Overview Label Studio had a remote import feature allowed users to import data from a remote web source, that was downloaded and could be viewed on the website. This feature could had been abused to download a HTML file that executed malicious JavaScript code in the context of the Label Studio website. Description The following code snippet in Label Studio showed that is a URL passed the SSRF verification checks, the contents of the file would be downloaded using the filename in the URL. 1. The file name that was set was retrieved from the URL. The downloaded file path could then be retrieved by sending a request to /api/projects/{projectid}/file-uploads?ids=[{downloadid}] where {projectid} was the ID of the project and {downloadid} was the ID of the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-fq23-g58m-799r

  2. Revision 1 · created ·

    Published from osv record GHSA-fq23-g58m-799r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-23633

Advisory: Cross-site Scripting Vulnerability on Data Import
IDs: CVE-2024-23633, GHSA-fq23-g58m-799r
Record: https://patchnext.com/advisories/cve-2024-23633 (revision 2, source checked 26 Oct 2026, 13:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: label-studio 1.10.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI label-studio: affected < 1.10.1; fixed in 1.10.1

## Suggested inspection (read-only)
- `python -m pip show label-studio`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on label-studio.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fq23-g58m-799r (OSV record GHSA-fq23-g58m-799r lists affected ranges: PyPI label-studio >=0 <1.10.1 (fixed))
- Verified: https://github.com/advisories/GHSA-fq23-g58m-799r (GitHub-reviewed advisory GHSA-fq23-g58m-799r lists affected ranges: PyPI label-studio >=0 <1.10.1)

Commands are suggestions: review each one before running it.

Loading voting…