Skip to content

← Actionable
Critical, CVSS 9.3amended

pymatgen vulnerable to arbitrary code execution when parsing a maliciously crafted JonesFaithfulTransformation transformation_string

CVE-2024-23346GHSA-vgv8-5cpj-qj2f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pymatgen 2024.2.20), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pymatgen

    Affected
    < 2024.2.20
    Fixed in
    2024.2.20

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.3 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2024-23346: 3.85% estimated exploitation activity in the next 30 days; percentile 90.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A critical security vulnerability exists in the JonesFaithfulTransformation.fromtransformationstr() method within the pymatgen library. This method insecurely utilizes eval() for processing input, enabling execution of arbitrary code when parsing untrusted input. This can be exploited when parsing a maliciously-created CIF file. Details The cause of the vulnerability is in pymatgen/symmetry/settings.py#L97C1-L111C108. The flawed code segment involves a regular expression operation followed by the use of eval(). Vulnerable code The use of eval, even with builtins set to None, is still a security risk. The BuiltinImporter class can be recovered with subclass traversal. PoC The vulnerability can be exploited as follows: Create a file vuln.cif with the following contents: Then, parse the cif file with the following code: Credits This vulnerability was found and disclosed by William Khem-Marquez.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vgv8-5cpj-qj2f

  2. Revision 1 · created ·

    Published from osv record GHSA-vgv8-5cpj-qj2f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-23346

Advisory: pymatgen vulnerable to arbitrary code execution when parsing a maliciously crafted JonesFaithfulTransformation transformation_string
IDs: CVE-2024-23346, GHSA-vgv8-5cpj-qj2f
Record: https://patchnext.com/advisories/cve-2024-23346 (revision 2, source checked 26 Oct 2026, 13:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pymatgen 2024.2.20. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pymatgen: affected < 2024.2.20; fixed in 2024.2.20

## Suggested inspection (read-only)
- `python -m pip show pymatgen`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pymatgen.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vgv8-5cpj-qj2f (OSV record GHSA-vgv8-5cpj-qj2f lists affected ranges: PyPI pymatgen >=0 <2024.2.20 (fixed))
- Verified: https://github.com/advisories/GHSA-vgv8-5cpj-qj2f (GitHub-reviewed advisory GHSA-vgv8-5cpj-qj2f lists affected ranges: PyPI pymatgen >=0 <2024.2.20)

Commands are suggestions: review each one before running it.

Loading voting…