Skip to content

← Actionable
Medium, CVSS 5.3amended

@hono/node-server cannot handle "double dots" in URL

CVE-2024-23340GHSA-rjq5-w47x-x359

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@hono/node-server 1.4.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2024-23340: 0.72% estimated exploitation activity in the next 30 days; percentile 54.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Since v1.3.0, we use our own Request object. This is great, but the url behavior is unexpected. In the standard API, if the URL contains .., here called "double dots", the URL string returned by Request will be in the resolved path. However, the url in our Request does not resolve double dots, so http://localhost/static/.. /foo.txt is returned. It will pass unresolved paths to the web application. This causes vulnerabilities like #123 when using serveStatic. Note: Modern web browsers and a latest curl command resolve double dots on the client side, so it does not affect you if the user uses them. However, problems may occur if accessed by a client that does not resolve them. Patches "v1.4.1" includes the change to fix this issue. Workarounds Don't use serveStatic.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-rjq5-w47x-x359

  2. Revision 1 · created ·

    Published from osv record GHSA-rjq5-w47x-x359

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-23340

Advisory: @hono/node-server cannot handle "double dots" in URL
IDs: CVE-2024-23340, GHSA-rjq5-w47x-x359
Record: https://patchnext.com/advisories/cve-2024-23340 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @hono/node-server 1.4.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @hono/node-server: affected >= 1.3.0, < 1.4.1; fixed in 1.4.1

## Suggested inspection (read-only)
- `npm ls @hono/node-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @hono/node-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rjq5-w47x-x359 (OSV record GHSA-rjq5-w47x-x359 lists affected ranges: npm @hono/node-server >=1.3.0 <1.4.1 (fixed))
- Verified: https://github.com/advisories/GHSA-rjq5-w47x-x359 (GitHub-reviewed advisory GHSA-rjq5-w47x-x359 lists affected ranges: npm @hono/node-server >=1.3.0 <1.4.1)

Commands are suggestions: review each one before running it.

Loading voting…