Vite dev server option server.fs.deny can be bypassed when hosted on case-insensitive filesystem
CVE-2024-23331GHSA-c24v-8rfc-w8vw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vite 5.0.12, 4.5.2, 3.2.8, 2.9.17), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm vite
- Affected
- >= 2.7.0, <= 2.9.16>= 3.0.0, <= 3.2.7>= 4.0.0, <= 4.5.1>= 5.0.0, <= 5.0.11
- Fixed in
- 4.5.2, 2.9.17, 5.0.12, 3.2.8
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-c24v-8rfc-w8vw lists affected ranges: npm vite >=2.7.0 =3.0.0 =4.0.0 =5.0.0 <5.0.12 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c24v-8rfc-w8vw lists affected ranges: npm vite >=2.7.0 =3.0.0 =4.0.0 =5.0.0 <=5.0.11
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2024-23331: 0.78% estimated exploitation activity in the next 30 days; percentile 56.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Vite dev server option server.fs.deny can be bypassed on case-insensitive file systems using case-augmented versions of filenames. Notably this affects servers hosted on Windows. This bypass is similar to https://nvd.nist.gov/vuln/detail/CVE-2023-34092 -- with surface area reduced to hosts having case-insensitive filesystems. Patches Fixed in vite@5.0.12, vite@4.5.2, vite@3.2.8, vite@2.9.17 Details Since picomatch defaults to case-sensitive glob matching, but the file server doesn't discriminate; a blacklist bypass is possible. See picomatch usage, where nocase is defaulted to false: https://github.com/vitejs/vite/blob/v5.1.0-beta.1/packages/vite/src/node/server/index.ts#L632 By requesting raw filesystem paths using augmented casing, the matcher derived from config.server.fs.deny fails to block access to sensitive files. PoC Setup 1. Created vanilla Vite project using npm create vite@latest on a Standard Azure hosted Windows 10 instance. - npm run dev -- --host 0.0.0.0 -…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-c24v-8rfc-w8vw
- Revision 1 · created ·
Published from osv record GHSA-c24v-8rfc-w8vw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-23331 Advisory: Vite dev server option `server.fs.deny` can be bypassed when hosted on case-insensitive filesystem IDs: CVE-2024-23331, GHSA-c24v-8rfc-w8vw Record: https://patchnext.com/advisories/cve-2024-23331 (revision 2, source checked 26 Oct 2026, 12:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vite 5.0.12, 4.5.2, 3.2.8, 2.9.17. A vendor fix does not mean a deployment is fixed. ## Affected components - npm vite: affected >= 2.7.0, <= 2.9.16; >= 3.0.0, <= 3.2.7; >= 4.0.0, <= 4.5.1; >= 5.0.0, <= 5.0.11; fixed in 4.5.2, 2.9.17, 5.0.12, 3.2.8 ## Suggested inspection (read-only) - `npm ls vite --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vite. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-c24v-8rfc-w8vw (OSV record GHSA-c24v-8rfc-w8vw lists affected ranges: npm vite >=2.7.0 =3.0.0 =4.0.0 =5.0.0 <5.0.12 (fixed)) - Verified: https://github.com/advisories/GHSA-c24v-8rfc-w8vw (GitHub-reviewed advisory GHSA-c24v-8rfc-w8vw lists affected ranges: npm vite >=2.7.0 =3.0.0 =4.0.0 =5.0.0 <=5.0.11) Commands are suggestions: review each one before running it.
Loading voting…