Apache RocketMQ Vulnerable to Unauthorized Exposure of Sensitive Data
CVE-2024-23321GHSA-q9w2-h4cw-8ghp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.rocketmq:rocketmq-all 5.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.rocketmq:rocketmq-all
- Affected
- >= 4.5.2, < 5.3.0
- Fixed in
- 5.3.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q9w2-h4cw-8ghp lists affected ranges: Maven org.apache.rocketmq:rocketmq-all >=4.5.2 <5.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-23321: 0.89% estimated exploitation activity in the next 30 days; percentile 59.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
For RocketMQ versions 5.2.0 and below, under certain conditions, there is a risk of exposure of sensitive Information to an unauthorized actor even if RocketMQ is enabled with authentication and authorization functions. An attacker, possessing regular user privileges or listed in the IP whitelist, could potentially acquire the administrator's account and password through specific interfaces. Such an action would grant them full control over RocketMQ, provided they have access to the broker IP address list. To mitigate these security threats, it is strongly advised that users upgrade to version 5.3.0 or newer. Additionally, we recommend users to use RocketMQ ACL 2.0 instead of the original RocketMQ ACL when upgrading to version Apache RocketMQ 5.3.0.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q9w2-h4cw-8ghp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-23321 Advisory: Apache RocketMQ Vulnerable to Unauthorized Exposure of Sensitive Data IDs: CVE-2024-23321, GHSA-q9w2-h4cw-8ghp Record: https://patchnext.com/advisories/cve-2024-23321 (revision 1, source checked 26 Oct 2026, 16:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.rocketmq:rocketmq-all 5.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.rocketmq:rocketmq-all: affected >= 4.5.2, < 5.3.0; fixed in 5.3.0 ## Suggested inspection (read-only) - Maven org.apache.rocketmq:rocketmq-all: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.rocketmq:rocketmq-all. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q9w2-h4cw-8ghp (GitHub-reviewed advisory GHSA-q9w2-h4cw-8ghp lists affected ranges: Maven org.apache.rocketmq:rocketmq-all >=4.5.2 <5.3.0) Commands are suggestions: review each one before running it.
Loading voting…