Skip to content

← Actionable
High, CVSS 7.2

Centreon updateContactHostCommands SQL Injection Remote Code Execution Vulnerability

CVE-2024-23118GHSA-2j4g-v4fv-rhwg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (centreon/centreon 22.10.15), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.2 · CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2024-23118: 53.41% estimated exploitation activity in the next 30 days; percentile 98.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Centreon updateContactHostCommands SQL Injection Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of Centreon. Authentication is required to exploit this vulnerability. The specific flaw exists within the updateContactHostCommands function. The issue results from the lack of proper validation of a user-supplied string before using it to construct SQL queries. An attacker can leverage this vulnerability to execute code in the context of the service account. Was ZDI-CAN-22298.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-2j4g-v4fv-rhwg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-23118

Advisory: Centreon updateContactHostCommands SQL Injection Remote Code Execution Vulnerability
IDs: CVE-2024-23118, GHSA-2j4g-v4fv-rhwg
Record: https://patchnext.com/advisories/cve-2024-23118 (revision 1, source checked 26 Oct 2026, 14:19 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: centreon/centreon 22.10.15. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist centreon/centreon: affected < 22.10.15; fixed in 22.10.15

## Suggested inspection (read-only)
- Packagist centreon/centreon: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on centreon/centreon.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2j4g-v4fv-rhwg (GitHub-reviewed advisory GHSA-2j4g-v4fv-rhwg lists affected ranges: Packagist centreon/centreon >=0 <22.10.15)

Commands are suggestions: review each one before running it.

Loading voting…