Skip to content

← Actionable
High, CVSS 7.5

Reading specially crafted serializable objects from an untrusted source may cause an infinite loop and denial of service

CVE-2024-22871GHSA-vr64-r9qj-h27f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.clojure:clojure 1.12.0-alpha9, 1.11.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.clojure:clojure

    Affected
    >= 1.7.0, < 1.11.2>= 1.12.0-alpha1, < 1.12.0-alpha9
    Fixed in
    1.12.0-alpha9, 1.11.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2024-22871: 1.53% estimated exploitation activity in the next 30 days; percentile 74.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Any program on the JVM may read serialized objects via java.io.ObjectInputStream.readObject(). Reading serialized objects from an untrusted source is inherently unsafe (this affects any program running on any version of the JVM) and is a prerequisite for this vulnerability. Clojure classes that represent infinite seqs (Cycle, infinite Repeat, and Iterate) do not define hashCode() and use the parent ASeq.hashCode(), which walks the seq to compute the hash, yielding an infinite loop. Classes like java.util.HashMap call hashCode() on keys during deserialization of a serialized map. The exploit requires: 1. Crafting a serialized HashMap object with an infinite seq object as a key. 2. Sending that to a program that reads serialized objects via ObjectInputStream.readObject(). This will cause the program to enter an infinite loop on the reading thread and thus a denial of service (DoS). The affected Clojure classes (Cycle, Repeat, Iterate) exist in Clojure 1.7.0-1.11.1,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vr64-r9qj-h27f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-22871

Advisory: Reading specially crafted serializable objects from an untrusted source may cause an infinite loop and denial of service
IDs: CVE-2024-22871, GHSA-vr64-r9qj-h27f
Record: https://patchnext.com/advisories/cve-2024-22871 (revision 1, source checked 26 Oct 2026, 16:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.clojure:clojure 1.12.0-alpha9, 1.11.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.clojure:clojure: affected >= 1.7.0, < 1.11.2; >= 1.12.0-alpha1, < 1.12.0-alpha9; fixed in 1.12.0-alpha9, 1.11.2

## Suggested inspection (read-only)
- Maven org.clojure:clojure: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.clojure:clojure.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vr64-r9qj-h27f (GitHub-reviewed advisory GHSA-vr64-r9qj-h27f lists affected ranges: Maven org.clojure:clojure >=1.7.0 =1.12.0-alpha1 <1.12.0-alpha9)

Commands are suggestions: review each one before running it.

Loading voting…