Skip to content

← Actionable
Critical, CVSS 9.8

Beetl Server-Side Template Injection vulnerability

CVE-2024-22533GHSA-9gh8-877r-g477

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.ibeetl:beetl-core 3.15.13.RELEASE), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2024-22533: 1.03% estimated exploitation activity in the next 30 days; percentile 63.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Before Beetl v3.15.13.RELEASE, the rendering template has a server-side template injection (SSTI) vulnerability. When the incoming template is controllable, it will be filtered by the DefaultNativeSecurityManager blacklist. Because blacklist filtering is not strict, the blacklist can be bypassed, leading to arbitrary code execution.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9gh8-877r-g477

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-22533

Advisory: Beetl Server-Side Template Injection vulnerability
IDs: CVE-2024-22533, GHSA-9gh8-877r-g477
Record: https://patchnext.com/advisories/cve-2024-22533 (revision 1, source checked 26 Oct 2026, 16:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: com.ibeetl:beetl-core 3.15.13.RELEASE. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven com.ibeetl:beetl-core: affected < 3.15.13.RELEASE; fixed in 3.15.13.RELEASE

## Suggested inspection (read-only)
- Maven com.ibeetl:beetl-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on com.ibeetl:beetl-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9gh8-877r-g477 (GitHub-reviewed advisory GHSA-9gh8-877r-g477 lists affected ranges: Maven com.ibeetl:beetl-core >=0 <3.15.13.RELEASE)

Commands are suggestions: review each one before running it.

Loading voting…