Skip to content

← Actionable
High, CVSS 8.3amended

yt-dlp: --exec command injection when using %q in yt-dlp on Windows (Bypass of CVE-2023-40581)

CVE-2024-22423GHSA-hjq6-52gw-2g7p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (yt-dlp 2024.4.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI yt-dlp

    Affected
    >= 2021.4.11, < 2024.4.9
    Fixed in
    2024.4.9

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.3 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H
EPSS
  • CVE-2024-22423: 1.43% estimated exploitation activity in the next 30 days; percentile 73.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The patch that addressed CVE-2023-40581 attempted to prevent RCE when using --exec with %q by replacing double quotes with two double quotes. However, this escaping is not sufficient, and still allows expansion of environment variables. Support for output template expansion in --exec, along with this vulnerable behavior, was added to yt-dlp in version 2021.04.11. Patches yt-dlp version 2024.04.09 fixes this issue by properly escaping %. It replaces them with %%cd:~,%, a variable that expands to nothing, leaving only the leading percent. Workarounds It is recommended to upgrade yt-dlp to version 2024.04.09 as soon as possible. Also, always be careful when using --exec, because while this specific vulnerability has been patched, using unvalidated input in shell commands is inherently dangerous. For Windows users who are not able to upgrade: - Avoid using any output template expansion in --exec other than {} (filepath). - If expansion in --exec is needed, verify the fields you…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-hjq6-52gw-2g7p

  2. Revision 1 · created ·

    Published from osv record GHSA-hjq6-52gw-2g7p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-22423

Advisory: yt-dlp: `--exec` command injection when using `%q` in yt-dlp on Windows (Bypass of CVE-2023-40581)
IDs: CVE-2024-22423, GHSA-hjq6-52gw-2g7p
Record: https://patchnext.com/advisories/cve-2024-22423 (revision 2, source checked 26 Oct 2026, 13:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: yt-dlp 2024.4.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI yt-dlp: affected >= 2021.4.11, < 2024.4.9; fixed in 2024.4.9

## Suggested inspection (read-only)
- `python -m pip show yt-dlp`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on yt-dlp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hjq6-52gw-2g7p (OSV record GHSA-hjq6-52gw-2g7p lists affected ranges: PyPI yt-dlp >=2021.04.11 <2024.04.09 (fixed))
- Verified: https://github.com/advisories/GHSA-hjq6-52gw-2g7p (GitHub-reviewed advisory GHSA-hjq6-52gw-2g7p lists affected ranges: PyPI yt-dlp >=2021.4.11 <2024.4.9)

Commands are suggestions: review each one before running it.

Loading voting…