JupyterLab vulnerable to potential authentication and CSRF tokens leak
CVE-2024-22421GHSA-44cc-43rp-5947
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jupyterlab 4.0.11, 3.6.7; notebook 7.0.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI jupyterlab
- Affected
- >= 4.0.0, <= 4.0.10<= 3.6.6
- Fixed in
- 3.6.7, 4.0.11
PyPI notebook
- Affected
- >= 7.0.0, <= 7.0.6
- Fixed in
- 7.0.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-44cc-43rp-5947 lists affected ranges: PyPI jupyterlab >=4.0.0 =0 =7.0.0 <7.0.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-44cc-43rp-5947 lists affected ranges: PyPI jupyterlab >=4.0.0 =0 =7.0.0 <=7.0.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:L
- EPSS
- CVE-2024-22421: 0.67% estimated exploitation activity in the next 30 days; percentile 52.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Users of JupyterLab who click on a malicious link may get their Authorization and XSRFToken tokens exposed to a third party when running an older jupyter-server version. Patches JupyterLab 4.1.0b2, 4.0.11, and 3.6.7 were patched. Workarounds No workaround has been identified, however users should ensure to upgrade jupyter-server to version 2.7.2 or newer which includes a redirect vulnerability fix. References Vulnerability reported by user @davwwwx via the bug bounty program sponsored by the European Commission and hosted on the Intigriti platform.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-44cc-43rp-5947
- Revision 1 · created ·
Published from osv record GHSA-44cc-43rp-5947
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-22421 Advisory: JupyterLab vulnerable to potential authentication and CSRF tokens leak IDs: CVE-2024-22421, GHSA-44cc-43rp-5947 Record: https://patchnext.com/advisories/cve-2024-22421 (revision 2, source checked 26 Oct 2026, 13:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jupyterlab 4.0.11, 3.6.7; notebook 7.0.7. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI jupyterlab: affected >= 4.0.0, <= 4.0.10; <= 3.6.6; fixed in 3.6.7, 4.0.11 - PyPI notebook: affected >= 7.0.0, <= 7.0.6; fixed in 7.0.7 ## Suggested inspection (read-only) - `python -m pip show jupyterlab`: prints the installed version. Run with the environment that serves production active. - `python -m pip show notebook`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jupyterlab, notebook. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-44cc-43rp-5947 (OSV record GHSA-44cc-43rp-5947 lists affected ranges: PyPI jupyterlab >=4.0.0 =0 =7.0.0 <7.0.7 (fixed)) - Verified: https://github.com/advisories/GHSA-44cc-43rp-5947 (GitHub-reviewed advisory GHSA-44cc-43rp-5947 lists affected ranges: PyPI jupyterlab >=4.0.0 =0 =7.0.0 <=7.0.6) Commands are suggestions: review each one before running it.
Loading voting…