Skip to content

← Actionable
Medium, CVSS 6.1amended

Whoogle Search Cross-site Scripting vulnerability

CVE-2024-22417GHSA-phg6-44m7-hx3h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (whoogle-search 0.8.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2024-22417: 0.64% estimated exploitation activity in the next 30 days; percentile 50.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Whoogle Search is a self-hosted metasearch engine. In versions 0.8.3 and prior, the element method in app/routes.py does not validate the user-controlled srctype and elementurl variables and passes them to the send method which sends a GET request on lines 339-343 in requests.py. The returned contents of the URL are then passed to and reflected back to the user in the sendfile function on line 484, together with the user-controlled srctype, which allows the attacker to control the HTTP response content type leading to a cross-site scripting vulnerability. An attacker could craft a special URL to point to a malicious website and send the link to a victim. The fact that the link would contain a trusted domain (e.g. from one of public Whoogle instances) could be used to trick the user into clicking the link.The malicious website could, for example, be a copy of a real website, meant to steal a person’s credentials to the website, or trick that person in another way. Version 0.8.4…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-phg6-44m7-hx3h

  2. Revision 1 · created ·

    Published from osv record GHSA-phg6-44m7-hx3h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-22417

Advisory: Whoogle Search Cross-site Scripting vulnerability
IDs: CVE-2024-22417, GHSA-phg6-44m7-hx3h
Record: https://patchnext.com/advisories/cve-2024-22417 (revision 2, source checked 26 Oct 2026, 13:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: whoogle-search 0.8.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI whoogle-search: affected < 0.8.4; fixed in 0.8.4

## Suggested inspection (read-only)
- `python -m pip show whoogle-search`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on whoogle-search.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-phg6-44m7-hx3h (OSV record GHSA-phg6-44m7-hx3h lists affected ranges: PyPI whoogle-search >=0 <0.8.4 (fixed))
- Verified: https://github.com/advisories/GHSA-phg6-44m7-hx3h (GitHub-reviewed advisory GHSA-phg6-44m7-hx3h lists affected ranges: PyPI whoogle-search >=0 <0.8.4)

Commands are suggestions: review each one before running it.

Loading voting…