Cross-Site Request Forgery on any API call in pyLoad may lead to admin privilege escalation
CVE-2024-22416GHSA-pgpj-v85q-h5fm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pyload-ng 0.5.0b3.dev78), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pyload-ng
- Affected
- < 0.5.0b3.dev78
- Fixed in
- 0.5.0b3.dev78
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pgpj-v85q-h5fm lists affected ranges: PyPI pyload-ng >=0 <0.5.0b3.dev78 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pgpj-v85q-h5fm lists affected ranges: PyPI pyload-ng >=0 <0.5.0b3.dev78
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2024-22416: 0.95% estimated exploitation activity in the next 30 days; percentile 61.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The pyload API allows any API call to be made using GET requests. Since the session cookie is not set to SameSite: strict, this opens the library up to severe attack possibilities via a Cross-Site Request Forgery (CSRF) attack. This proof of concept shows how an unauthenticated user could trick the administrator's browser into creating a new admin user. PoC We host the following HTML file on an attacker-controlled server. If we now trick an administrator into visiting our malicious page at https://attacker.com/CSRF.html, we see that their browser will make a request to /api/adduser/%22hacker%22,%22hacker%22, adding a new administrator to the pyload application. The attacker can now authenticate as this newly created administrator user with the username hacker and password hacker. Impact Any API call can be made via a CSRF attack by an unauthenticated user.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-pgpj-v85q-h5fm
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-pgpj-v85q-h5fm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-22416 Advisory: Cross-Site Request Forgery on any API call in pyLoad may lead to admin privilege escalation IDs: CVE-2024-22416, GHSA-pgpj-v85q-h5fm Record: https://patchnext.com/advisories/cve-2024-22416 (revision 3, source checked 26 Oct 2026, 13:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pyload-ng 0.5.0b3.dev78. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pyload-ng: affected < 0.5.0b3.dev78; fixed in 0.5.0b3.dev78 ## Suggested inspection (read-only) - `python -m pip show pyload-ng`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pyload-ng. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pgpj-v85q-h5fm (OSV record GHSA-pgpj-v85q-h5fm lists affected ranges: PyPI pyload-ng >=0 <0.5.0b3.dev78 (fixed)) - Verified: https://github.com/advisories/GHSA-pgpj-v85q-h5fm (GitHub-reviewed advisory GHSA-pgpj-v85q-h5fm lists affected ranges: PyPI pyload-ng >=0 <0.5.0b3.dev78) Commands are suggestions: review each one before running it.
Loading voting…