Skip to content

← Actionable
Medium, CVSS 6.5

Cross-site scripting (XSS) in Action messages on Avo

CVE-2024-22411GHSA-g8vp-2v5p-9qfh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (avo 3.3.0, 2.47.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems avo

    Affected
    >= 3.0.0.beta1, < 3.3.0< 2.47.0
    Fixed in
    3.3.0, 2.47.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L
EPSS
  • CVE-2024-22411: 0.71% estimated exploitation activity in the next 30 days; percentile 53.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Avo is a framework to create admin panels for Ruby on Rails apps. In Avo 3 pre12, any HTML inside text that is passed to error or succeed in an Avo::BaseAction subclass will be rendered directly without sanitization in the toast/notification that appears in the UI on Action completion. A malicious user could exploit this vulnerability to trigger a cross site scripting attack on an unsuspecting user. This issue has been addressed in the 3.3.0 and 2.47.0 releases of Avo. Users are advised to upgrade.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-g8vp-2v5p-9qfh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-22411

Advisory: Cross-site scripting (XSS) in Action messages on Avo
IDs: CVE-2024-22411, GHSA-g8vp-2v5p-9qfh
Record: https://patchnext.com/advisories/cve-2024-22411 (revision 1, source checked 26 Oct 2026, 15:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: avo 3.3.0, 2.47.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems avo: affected >= 3.0.0.beta1, < 3.3.0; < 2.47.0; fixed in 3.3.0, 2.47.0

## Suggested inspection (read-only)
- RubyGems avo: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on avo.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-g8vp-2v5p-9qfh (GitHub-reviewed advisory GHSA-g8vp-2v5p-9qfh lists affected ranges: RubyGems avo >=3.0.0.beta1 =0 <2.47.0)

Commands are suggestions: review each one before running it.

Loading voting…