Skip to content

← Actionable
Low, CVSS 2.7

SQL Injection in Harbor scan log API

CVE-2024-22261GHSA-vw63-824v-qf2j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/goharbor/harbor 2.10.2, 2.9.4, 2.8.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
2.7 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2024-22261: 0.42% estimated exploitation activity in the next 30 days; percentile 36.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A user with an administrator, projectadmin, or projectmaintainer role could utilize and exploit SQL Injection to allow the execution of any Postgres function or the extraction of sensitive information from the database through this API: The SQL injection might happen in the code: https://github.com/goharbor/harbor/blob/9b7c1a2274fbc5ea16e19a484532f86c08926577/src/pkg/task/task.go#L241 Because raw SQL executed in ormer.Raw(Sql).QueryRows() is PrepareStatement. In the driver of Postgres, one PrepareStatement must contain only ONE SQL command, see https://www.postgresql.org/docs/15/libpq-exec.html#LIBPQ-PQPREPARE. The SQL should start with: Adding a delete/update operation by appending malicious content to the current SQL is impossible. Furthermore, the query result of the task is just an intermediate result, the task ID is used to locate the job log file, and the response only contains the content of the job log file. so this vulnerability can be used to execute SQL functions,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vw63-824v-qf2j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-22261

Advisory: SQL Injection in Harbor scan log API
IDs: CVE-2024-22261, GHSA-vw63-824v-qf2j
Record: https://patchnext.com/advisories/cve-2024-22261 (revision 1, source checked 26 Oct 2026, 15:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/goharbor/harbor 2.10.2, 2.9.4, 2.8.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/goharbor/harbor: affected < 2.8.6; >= 2.9.0, < 2.9.4; >= 2.10.0, < 2.10.2; fixed in 2.8.6, 2.10.2, 2.9.4

## Suggested inspection (read-only)
- Go github.com/goharbor/harbor: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/goharbor/harbor.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vw63-824v-qf2j (GitHub-reviewed advisory GHSA-vw63-824v-qf2j lists affected ranges: Go github.com/goharbor/harbor >=0 =2.9.0 =2.10.0 <2.10.2)

Commands are suggestions: review each one before running it.

Loading voting…