Skip to content

← Actionable
Medium, CVSS 6.5

phpMyFAQ sharing FAQ functionality can easily be abused for phishing purposes

CVE-2024-22208GHSA-9hhf-xmcw-r3xg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpmyfaq/phpmyfaq 3.2.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
EPSS
  • CVE-2024-22208: 0.74% estimated exploitation activity in the next 30 days; percentile 54.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The 'sharing FAQ' functionality allows any unauthenticated actor to misuse the phpMyFAQ application to send arbitrary emails to a large range of targets. Details The phpMyFAQ application has a functionality where anyone can share a FAQ item to others. The front-end of this functionality allows any phpMyFAQ articles to be shared with 5 email addresses. The application will then send these 5 emails. However, there are no controls over what link and content are shared. Furthermore, any unauthenticated actor can perform this action. There is a CAPTCHA in place, however the amount of people you email with a single request is not limited to 5 by the backend. An attacker can thus solve a single CAPTCHA and send thousands of emails at once. PoC We send the following form and capture the request. We now change the body to contain 50 email addresses instead of just 1, and send the request. The attacker can also change the body of the email to any phishing message. Below are the logs of…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9hhf-xmcw-r3xg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-22208

Advisory: phpMyFAQ sharing FAQ functionality can easily be abused for phishing purposes
IDs: CVE-2024-22208, GHSA-9hhf-xmcw-r3xg
Record: https://patchnext.com/advisories/cve-2024-22208 (revision 1, source checked 26 Oct 2026, 14:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: phpmyfaq/phpmyfaq 3.2.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist phpmyfaq/phpmyfaq: affected < 3.2.5; fixed in 3.2.5

## Suggested inspection (read-only)
- Packagist phpmyfaq/phpmyfaq: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on phpmyfaq/phpmyfaq.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9hhf-xmcw-r3xg (GitHub-reviewed advisory GHSA-9hhf-xmcw-r3xg lists affected ranges: Packagist phpmyfaq/phpmyfaq >=0 <3.2.5)

Commands are suggestions: review each one before running it.

Loading voting…