@clerk/nextjs auth() and getAuth() methods vulnerable to insecure direct object reference (IDOR)
CVE-2024-22206GHSA-q6w5-jg5q-47vg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@clerk/nextjs 4.29.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @clerk/nextjs
- Affected
- >= 4.7.0, < 4.29.3
- Fixed in
- 4.29.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q6w5-jg5q-47vg lists affected ranges: npm @clerk/nextjs >=4.7.0 <4.29.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q6w5-jg5q-47vg lists affected ranges: npm @clerk/nextjs >=4.7.0 <4.29.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.0 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2024-22206: 0.68% estimated exploitation activity in the next 30 days; percentile 52.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Unauthorized access or privilege escalation due to a logic flaw in auth() in the App Router or getAuth() in the Pages Router. Affected Versions All applications that that use @clerk/nextjs versions in the range of = 4.7.0,< 4.29.3 in a Next.js backend to authenticate API Routes, App Router, or Route handlers. Specifically, those that call auth() in the App Router or getAuth() in the Pages Router. Only the @clerk/nextjs SDK is impacted. Other SDKs, including other Javascript-based SDKs, are not impacted. Patches Fix included in @clerk/nextjs@4.29.3. References - https://clerk.com/changelog/2024-01-12 - https://github.com/clerk/javascript/releases/tag/%40clerk%2Fnextjs%404.29.3
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-q6w5-jg5q-47vg
- Revision 1 · created ·
Published from osv record GHSA-q6w5-jg5q-47vg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-22206 Advisory: @clerk/nextjs auth() and getAuth() methods vulnerable to insecure direct object reference (IDOR) IDs: CVE-2024-22206, GHSA-q6w5-jg5q-47vg Record: https://patchnext.com/advisories/cve-2024-22206 (revision 2, source checked 26 Oct 2026, 12:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @clerk/nextjs 4.29.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @clerk/nextjs: affected >= 4.7.0, < 4.29.3; fixed in 4.29.3 ## Suggested inspection (read-only) - `npm ls @clerk/nextjs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @clerk/nextjs. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-q6w5-jg5q-47vg (OSV record GHSA-q6w5-jg5q-47vg lists affected ranges: npm @clerk/nextjs >=4.7.0 <4.29.3 (fixed)) - Verified: https://github.com/advisories/GHSA-q6w5-jg5q-47vg (GitHub-reviewed advisory GHSA-q6w5-jg5q-47vg lists affected ranges: npm @clerk/nextjs >=4.7.0 <4.29.3) Commands are suggestions: review each one before running it.
Loading voting…