Skip to content

← Actionable
Medium, CVSS 5.3amended

Whoogle Search Path Traversal vulnerability

CVE-2024-22204GHSA-hh2q-qv66-jcqg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (whoogle-search 0.8.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2024-22204: 0.76% estimated exploitation activity in the next 30 days; percentile 55.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Whoogle Search is a self-hosted metasearch engine. Versions 0.8.3 and prior have a limited file write vulnerability when the configuration options in Whoogle are enabled. The config function in app/routes.py does not validate the user-controlled name variable on line 447 and configdata variable on line 437. The name variable is insecurely concatenated in os.path.join, leading to path manipulation. The POST data from the configdata variable is saved with pickle.dump which leads to a limited file write. However, the data that is saved is earlier transformed into a dictionary and the url key value pair is added before the file is saved on the system. All in all, the issue allows us to save and overwrite files on the system that the application has permissions to, with a dictionary containing arbitrary data and the url key value, which is a limited file write. Version 0.8.4 contains a patch for this issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-hh2q-qv66-jcqg

  2. Revision 1 · created ·

    Published from osv record GHSA-hh2q-qv66-jcqg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-22204

Advisory: Whoogle Search Path Traversal vulnerability
IDs: CVE-2024-22204, GHSA-hh2q-qv66-jcqg
Record: https://patchnext.com/advisories/cve-2024-22204 (revision 2, source checked 26 Oct 2026, 13:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: whoogle-search 0.8.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI whoogle-search: affected < 0.8.4; fixed in 0.8.4

## Suggested inspection (read-only)
- `python -m pip show whoogle-search`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on whoogle-search.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hh2q-qv66-jcqg (OSV record GHSA-hh2q-qv66-jcqg lists affected ranges: PyPI whoogle-search >=0 <0.8.4 (fixed))
- Verified: https://github.com/advisories/GHSA-hh2q-qv66-jcqg (GitHub-reviewed advisory GHSA-hh2q-qv66-jcqg lists affected ranges: PyPI whoogle-search >=0 <0.8.4)

Commands are suggestions: review each one before running it.

Loading voting…