Skip to content

← Actionable
Critical, CVSS 9.3

Django Template Engine Vulnerable to XSS

CVE-2024-22199GHSA-4mq2-gc4j-cmw6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/gofiber/template/django/v3 3.1.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:H/A:N
EPSS
  • CVE-2024-22199: 0.48% estimated exploitation activity in the next 30 days; percentile 41.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Vulnerability Type: Cross-Site Scripting (XSS) Affected Users: All users of the Django template engine for Fiber prior to the patch. This vulnerability specifically impacts web applications that render user-supplied data through this template engine, potentially leading to the execution of malicious scripts in users' browsers when visiting affected web pages. Patches The vulnerability has been addressed. The template engine now defaults to having autoescape set to true, effectively mitigating the risk of XSS attacks. Users are advised to upgrade to the latest version of the Django template engine for Fiber, where this security update is implemented. Ensure that the version of the template engine being used is the latest, post-patch version. Workarounds For users unable to upgrade immediately to the patched version, a workaround involves manually implementing autoescaping within individual Django templates. This method includes adding specific tags in the template to control…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4mq2-gc4j-cmw6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-22199

Advisory: Django Template Engine Vulnerable to XSS
IDs: CVE-2024-22199, GHSA-4mq2-gc4j-cmw6
Record: https://patchnext.com/advisories/cve-2024-22199 (revision 1, source checked 26 Oct 2026, 15:03 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/gofiber/template/django/v3 3.1.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/gofiber/template/django/v3: affected < 3.1.9; fixed in 3.1.9

## Suggested inspection (read-only)
- Go github.com/gofiber/template/django/v3: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/gofiber/template/django/v3.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4mq2-gc4j-cmw6 (GitHub-reviewed advisory GHSA-4mq2-gc4j-cmw6 lists affected ranges: Go github.com/gofiber/template/django/v3 >=0 <3.1.9)

Commands are suggestions: review each one before running it.

Loading voting…