cdo-local-uuid vulnerable to insertion of artifact derived from developer's Present Working Directory into demonstration code
CVE-2024-22194GHSA-rgrf-6mf5-m882
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (case-utils 0.14.1, 0.13.1, 0.12.1, 0.11.1, 0.10.1, 0.9.1, 0.8.1, 0.7.1, 0.6.1, 0.5.1; cdo-local-uuid 0.5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI case-utils
- Affected
- >= 0.5.0, <= 0.5.0>= 0.6.0, <= 0.6.0>= 0.7.0, <= 0.7.0>= 0.8.0, <= 0.8.0>= 0.9.0, <= 0.9.0>= 0.10.0, <= 0.10.0>= 0.11.0, <= 0.11.0>= 0.12.0, <= 0.12.0>= 0.13.0, <= 0.13.0>= 0.14.0, <= 0.14.0
- Fixed in
- 0.11.1, 0.13.1, 0.8.1, 0.12.1, 0.9.1, 0.5.1, 0.6.1, 0.10.1, 0.14.1, 0.7.1
PyPI cdo-local-uuid
- Affected
- >= 0.4.0, <= 0.4.0
- Fixed in
- 0.5.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rgrf-6mf5-m882 lists affected ranges: PyPI cdo-local-uuid >=0.4.0 =0.5.0 =0.6.0 =0.7.0 =0.8.0 =0.9.0 =0.10.0 =0.11.0 =0.12.0 =0.13.0 =0.14.0 <0.14.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rgrf-6mf5-m882 lists affected ranges: PyPI cdo-local-uuid >=0.4.0 =0.5.0 =0.6.0 =0.7.0 =0.8.0 =0.9.0 =0.10.0 =0.11.0 =0.12.0 =0.13.0 =0.14.0 <=0.14.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 0.5 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2024-22194: 0.41% estimated exploitation activity in the next 30 days; percentile 35.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact What kind of vulnerability is it? Who is impacted? An information leakage vulnerability is present in cdo-local-uuid at version 0.4.0, and in case-utils in unpatched versions (matching the pattern 0.x.0) at and since 0.5.0, before 0.15.0. The vulnerability stems from a Python function, cdolocaluuid.localuuid(), and its original implementation caseutils.localuuid(). Henceforth, both will be called localuuid(). localuuid() generates UUIDv5s using a deterministic pseudorandom number stream. This was written to make graph application demonstrations generate consistent, version-controllable output with minimal noise caused by demonstration re-runs. Part of the information used to keep individual examples' generated output distinct from one another is seed information from the caller's environment, particularly the program's argument vector. The present working directory is also included as part of the seed information, but for reasons including maintaining user environment privacy,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-rgrf-6mf5-m882
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-rgrf-6mf5-m882
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-22194 Advisory: cdo-local-uuid vulnerable to insertion of artifact derived from developer's Present Working Directory into demonstration code IDs: CVE-2024-22194, GHSA-rgrf-6mf5-m882 Record: https://patchnext.com/advisories/cve-2024-22194 (revision 3, source checked 26 Oct 2026, 13:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 0.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: case-utils 0.14.1, 0.13.1, 0.12.1, 0.11.1, 0.10.1, 0.9.1, 0.8.1, 0.7.1, 0.6.1, 0.5.1; cdo-local-uuid 0.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI case-utils: affected >= 0.5.0, <= 0.5.0; >= 0.6.0, <= 0.6.0; >= 0.7.0, <= 0.7.0; >= 0.8.0, <= 0.8.0; >= 0.9.0, <= 0.9.0; >= 0.10.0, <= 0.10.0; >= 0.11.0, <= 0.11.0; >= 0.12.0, <= 0.12.0; >= 0.13.0, <= 0.13.0; >= 0.14.0, <= 0.14.0; fixed in 0.11.1, 0.13.1, 0.8.1, 0.12.1, 0.9.1, 0.5.1, 0.6.1, 0.10.1, 0.14.1, 0.7.1 - PyPI cdo-local-uuid: affected >= 0.4.0, <= 0.4.0; fixed in 0.5.0 ## Suggested inspection (read-only) - `python -m pip show case-utils`: prints the installed version. Run with the environment that serves production active. - `python -m pip show cdo-local-uuid`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on case-utils, cdo-local-uuid. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-rgrf-6mf5-m882 (OSV record GHSA-rgrf-6mf5-m882 lists affected ranges: PyPI cdo-local-uuid >=0.4.0 =0.5.0 =0.6.0 =0.7.0 =0.8.0 =0.9.0 =0.10.0 =0.11.0 =0.12.0 =0.13.0 =0.14.0 <0.14.1 (fixed)) - Verified: https://github.com/advisories/GHSA-rgrf-6mf5-m882 (GitHub-reviewed advisory GHSA-rgrf-6mf5-m882 lists affected ranges: PyPI cdo-local-uuid >=0.4.0 =0.5.0 =0.6.0 =0.7.0 =0.8.0 =0.9.0 =0.10.0 =0.11.0 =0.12.0 =0.13.0 =0.14.0 <=0.14.0) Commands are suggestions: review each one before running it.
Loading voting…