Skip to content

← Actionable
Low, CVSS 3.5amended

vantage6 may create unencrypted tasks in encrypted collaboration

CVE-2024-22193GHSA-rjmv-52mp-gjrr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vantage6 4.2.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI vantage6

    Affected
    < 4.2.0
    Fixed in
    4.2.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N
EPSS
  • CVE-2024-22193: 0.26% estimated exploitation activity in the next 30 days; percentile 17.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact There are no checks on whether the input is encrypted if a task is created in an encrypted collaboration. Therefore, a user may accidentally create a task with sensitive input data that will then be stored unencrypted in a database. Workarounds This is not an issue with the normal workflow, only if e.g. a user with the python client sets encryption to the wrong value.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-rjmv-52mp-gjrr

  2. Revision 1 · created ·

    Published from osv record GHSA-rjmv-52mp-gjrr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-22193

Advisory: vantage6 may create unencrypted tasks in encrypted collaboration
IDs: CVE-2024-22193, GHSA-rjmv-52mp-gjrr
Record: https://patchnext.com/advisories/cve-2024-22193 (revision 2, source checked 26 Oct 2026, 13:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vantage6 4.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI vantage6: affected < 4.2.0; fixed in 4.2.0

## Suggested inspection (read-only)
- `python -m pip show vantage6`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vantage6.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rjmv-52mp-gjrr (OSV record GHSA-rjmv-52mp-gjrr lists affected ranges: PyPI vantage6 >=0 <4.2.0 (fixed))
- Verified: https://github.com/advisories/GHSA-rjmv-52mp-gjrr (GitHub-reviewed advisory GHSA-rjmv-52mp-gjrr lists affected ranges: PyPI vantage6 >=0 <4.2.0)

Commands are suggestions: review each one before running it.

Loading voting…