avo vulnerable to stored cross-site scripting (XSS) in key_value field
CVE-2024-22191GHSA-ghjv-mh6x-7q6h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (avo 3.2.4, 2.47.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems avo
- Affected
- >= 3.0.0.beta1, <= 3.2.3<= 2.46.0
- Fixed in
- 3.2.4, 2.47.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-ghjv-mh6x-7q6h lists affected ranges: RubyGems avo >=3.0.0.beta1 =0 <=2.46.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2024-22191: 0.74% estimated exploitation activity in the next 30 days; percentile 54.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A stored cross-site scripting (XSS) vulnerability was found in the keyvalue field of Avo v3.2.3. This vulnerability could allow an attacker to execute arbitrary JavaScript code in the victim's browser. Details The value of the keyvalue is inserted directly into the HTML code. In the current version of Avo (possibly also older versions), the value is not properly sanitized before it is inserted into the HTML code. This vulnerability can be exploited by an attacker to inject malicious JavaScript code into the keyvalue field. When a victim views the page containing the malicious code, the code will be executed in their browser. In avo/fields/common/keyvaluecomponent.html.erb the value is taken in lines 38 and 49 and seems to be interpreted directly as html in lines 44 and 55. PoC To reproduce the vulnerability, follow these steps: 1. Edit an entry with a keyvalue field. 2. Enter the following payload into the value field: 3. Save the entry. 4. Go to the index page and click on…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-ghjv-mh6x-7q6h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-22191 Advisory: avo vulnerable to stored cross-site scripting (XSS) in key_value field IDs: CVE-2024-22191, GHSA-ghjv-mh6x-7q6h Record: https://patchnext.com/advisories/cve-2024-22191 (revision 1, source checked 26 Oct 2026, 15:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: avo 3.2.4, 2.47.0. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems avo: affected >= 3.0.0.beta1, <= 3.2.3; <= 2.46.0; fixed in 3.2.4, 2.47.0 ## Suggested inspection (read-only) - RubyGems avo: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on avo. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-ghjv-mh6x-7q6h (GitHub-reviewed advisory GHSA-ghjv-mh6x-7q6h lists affected ranges: RubyGems avo >=3.0.0.beta1 =0 <=2.46.0) Commands are suggestions: review each one before running it.
Loading voting…