TYPO3 Install Tool vulnerable to Code Execution
CVE-2024-22188GHSA-5w2h-59j3-8x5w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (typo3/cms-core 13.0.1, 12.4.11, 11.5.35, 10.4.43, 9.5.46, 8.7.57), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist typo3/cms-core
- Affected
- >= 8.0.0, <= 8.7.56>= 9.0.0, <= 9.5.45>= 10.0.0, <= 10.4.42>= 11.0.0, <= 11.5.34>= 12.0.0, <= 12.4.10>= 13.0.0, <= 13.0.0
- Fixed in
- 8.7.57, 12.4.11, 9.5.46, 10.4.43, 11.5.35, 13.0.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5w2h-59j3-8x5w lists affected ranges: Packagist typo3/cms-core >=8.0.0 =9.0.0 =10.0.0 =11.0.0 =12.0.0 =13.0.0 <=13.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-22188: 2.02% estimated exploitation activity in the next 30 days; percentile 80.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Problem Several settings in the Install Tool for configuring the path to system binaries were vulnerable to code execution. Exploiting this vulnerability requires an administrator-level backend user account with system maintainer permissions. The corresponding change for this advisory involves enforcing the known disadvantages described in TYPO3-PSA-2020-002: Protecting Install Tool with Sudo Mode. Solution Update to TYPO3 versions 8.7.57 ELTS, 9.5.46 ELTS, 10.4.43 ELTS, 11.5.35 LTS, 12.4.11 LTS, 13.0.1 that fix the problem described. Credits Thanks to Rickmer Frier & Daniel Jonka who reported this issue and to TYPO3 core & security team member Benjamin Franzke who fixed the issue. References TYPO3-CORE-SA-2024-002
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5w2h-59j3-8x5w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-22188 Advisory: TYPO3 Install Tool vulnerable to Code Execution IDs: CVE-2024-22188, GHSA-5w2h-59j3-8x5w Record: https://patchnext.com/advisories/cve-2024-22188 (revision 1, source checked 26 Oct 2026, 14:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: typo3/cms-core 13.0.1, 12.4.11, 11.5.35, 10.4.43, 9.5.46, 8.7.57. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist typo3/cms-core: affected >= 8.0.0, <= 8.7.56; >= 9.0.0, <= 9.5.45; >= 10.0.0, <= 10.4.42; >= 11.0.0, <= 11.5.34; >= 12.0.0, <= 12.4.10; >= 13.0.0, <= 13.0.0; fixed in 8.7.57, 12.4.11, 9.5.46, 10.4.43, 11.5.35, 13.0.1 ## Suggested inspection (read-only) - Packagist typo3/cms-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on typo3/cms-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5w2h-59j3-8x5w (GitHub-reviewed advisory GHSA-5w2h-59j3-8x5w lists affected ranges: Packagist typo3/cms-core >=8.0.0 =9.0.0 =10.0.0 =11.0.0 =12.0.0 =13.0.0 <=13.0.0) Commands are suggestions: review each one before running it.
Loading voting…