Integer overflow in cmark-gfm table parsing extension leads to heap memory corruption
CVE-2024-22051GHSA-fmx4-26r3-wxpf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (commonmarker 0.23.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems commonmarker
- Affected
- < 0.23.4
- Fixed in
- 0.23.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fmx4-26r3-wxpf lists affected ranges: RubyGems commonmarker >=0 <0.23.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2024-22051: 1.45% estimated exploitation activity in the next 30 days; percentile 73.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact CommonMarker uses cmark-gfm for rendering Github Flavored Markdown. An integer overflow in cmark-gfm's table row parsing may lead to heap memory corruption when parsing tables who's marker rows contain more than UINT16MAX columns. The impact of this heap corruption ranges from Information Leak to Arbitrary Code Execution. If affected versions of CommonMarker are used for rendering remote user controlled markdown, this vulnerability may lead to Remote Code Execution (RCE). Patches This vulnerability has been patched in the following CommonMarker release: - v0.23.4 Workarounds The vulnerability exists in the table markdown extensions of cmark-gfm. Disabling any use of the table extension will prevent this vulnerability from being triggered. References - https://github.com/github/cmark-gfm/security/advisories/GHSA-mc3g-88wq-6f4x Acknowledgements We would like to thank Felix Wilhelm of Google's Project Zero for reporting this vulnerability For more information If you have any…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fmx4-26r3-wxpf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-22051 Advisory: Integer overflow in cmark-gfm table parsing extension leads to heap memory corruption IDs: CVE-2024-22051, GHSA-fmx4-26r3-wxpf Record: https://patchnext.com/advisories/cve-2024-22051 (revision 1, source checked 26 Oct 2026, 15:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: commonmarker 0.23.4. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems commonmarker: affected < 0.23.4; fixed in 0.23.4 ## Suggested inspection (read-only) - RubyGems commonmarker: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on commonmarker. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fmx4-26r3-wxpf (GitHub-reviewed advisory GHSA-fmx4-26r3-wxpf lists affected ranges: RubyGems commonmarker >=0 <0.23.4) Commands are suggestions: review each one before running it.
Loading voting…