Skip to content

← Actionable
Low, CVSS 3.1

Race Condition leading to logging errors

CVE-2024-22047GHSA-hjp3-5g2q-7jww

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (audited 5.3.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems audited

    Affected
    >= 4.0.0, < 5.3.3
    Fixed in
    5.3.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.1 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2024-22047: 0.50% estimated exploitation activity in the next 30 days; percentile 42.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In certain setups with threaded web servers, Audited's use of Thread.current can incorrectly attributed audits to the wrong user. Fixed in 5.3.3. In March, @convisoappsec noticed that the library in question had a Race Condition problem, which caused logs to be registered at times with different users than those who performed the genuine actions. - The first issue we identified was from November 2021: https://github.com/collectiveidea/audited/issues/601 - So the solution was implemented in the following Pull Request: https://github.com/collectiveidea/audited/pull/669 - And the feature was published in version 5.3.3: RELEASE: https://github.com/collectiveidea/audited/pull/671

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hjp3-5g2q-7jww

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-22047

Advisory: Race Condition leading to logging errors
IDs: CVE-2024-22047, GHSA-hjp3-5g2q-7jww
Record: https://patchnext.com/advisories/cve-2024-22047 (revision 1, source checked 26 Oct 2026, 15:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: audited 5.3.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems audited: affected >= 4.0.0, < 5.3.3; fixed in 5.3.3

## Suggested inspection (read-only)
- RubyGems audited: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on audited.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hjp3-5g2q-7jww (GitHub-reviewed advisory GHSA-hjp3-5g2q-7jww lists affected ranges: RubyGems audited >=4.0.0 <5.3.3)

Commands are suggestions: review each one before running it.

Loading voting…