A vulnerability in Node.js has been identified, allowing for a Denial of Service (DoS) attack through resource exhaustion when using the fetch() function to retrieve content from an untrusted URL.
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (node 21.6.2, 20.11.1, 18.19.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
runtime node
- Affected
- >= 18.0.0, < 18.19.1>= 20.0.0, < 20.11.1>= 21.0.0, < 21.6.2
- Fixed in
- 20.11.1, 21.6.2, 18.19.1
Sources
- raw.githubusercontent.com runtime security intelligence
Node.js security working group core entry 138 lists CVE-2024-22025 affecting node >=18.0.0 =20.0.0 =21.0.0 <21.6.2
VerifiedObserved Structured Node.js security-wg core vulnerability record maintained by the Node.js project.
- nodejs.org runtime security intelligence
The nodejs.org release index dates the first patched release for CVE-2024-22025 to 2024-02-13.
VerifiedObserved Official nodejs.org release index (dist/index.json).
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2024-22025: 1.31% estimated exploitation activity in the next 30 days; percentile 70.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability in Node.js has been identified, allowing for a Denial of Service (DoS) attack through resource exhaustion when using the fetch() function to retrieve content from an untrusted URL.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · published ·
Published from vendor_advisory record nodejs-security-wg:core:138
- Revision 1 · created ·
Created from vendor_advisory record nodejs-security-wg:core:138
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-22025 Advisory: A vulnerability in Node.js has been identified, allowing for a Denial of Service (DoS) attack through resource exhaustion when using the fetch() function to retrieve content from an untrusted URL. IDs: CVE-2024-22025 Record: https://patchnext.com/advisories/cve-2024-22025 (revision 2, source checked 26 Oct 2026, 16:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: node 21.6.2, 20.11.1, 18.19.1. A vendor fix does not mean a deployment is fixed. ## Affected components - runtime node: affected >= 18.0.0, < 18.19.1; >= 20.0.0, < 20.11.1; >= 21.0.0, < 21.6.2; fixed in 20.11.1, 21.6.2, 18.19.1 ## Suggested inspection (read-only) - runtime node: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on node. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://raw.githubusercontent.com/nodejs/security-wg/main/vuln/core/138.json (Node.js security working group core entry 138 lists CVE-2024-22025 affecting node >=18.0.0 =20.0.0 =21.0.0 <21.6.2) - Verified: https://nodejs.org/dist/index.json (The nodejs.org release index dates the first patched release for CVE-2024-22025 to 2024-02-13.) Commands are suggestions: review each one before running it.
Loading voting…