Skip to content

← Actionable
Medium, CVSS 6.1amended

Cross-site scripting vulnerability in TinyMCE plugins

CVE-2024-21910GHSA-r8hm-w5f7-wj39

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (django-tinymce 3.4.0; tinymce 5.10.0; tinymce/tinymce 5.10.0; tinymce 5.10.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2024-21910: 0.96% estimated exploitation activity in the next 30 days; percentile 61.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A cross-site scripting (XSS) vulnerability was discovered in the URL processing logic of the image and link plugins. The vulnerability allowed arbitrary JavaScript execution when updating an image or link using a specially crafted URL. This issue only impacted users while editing and the dangerous URLs were stripped in any content extracted from the editor. This impacts all users who are using TinyMCE 5.9.2 or lower. Patches This vulnerability has been patched in TinyMCE 5.10.0 by improved sanitization logic when updating URLs in the relevant plugins. Workarounds To work around this vulnerability, either: - Upgrade to TinyMCE 5.10.0 or higher - Disable the image and link plugins Acknowledgements Tiny Technologies would like to thank Yakir6 for discovering this vulnerability. References https://www.tiny.cloud/docs/release-notes/release-notes510/#securityfixes For more information If you have any questions or comments about this advisory: Email us at infosec@tiny.cloud Open an…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-r8hm-w5f7-wj39

  2. Revision 1 · created ·

    Published from osv record GHSA-r8hm-w5f7-wj39

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-21910

Advisory: Cross-site scripting vulnerability in TinyMCE plugins
IDs: CVE-2024-21910, GHSA-r8hm-w5f7-wj39
Record: https://patchnext.com/advisories/cve-2024-21910 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: django-tinymce 3.4.0; tinymce 5.10.0; tinymce/tinymce 5.10.0; tinymce 5.10.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI django-tinymce: affected < 3.4.0; fixed in 3.4.0
- NuGet tinymce: affected < 5.10.0; fixed in 5.10.0
- Packagist tinymce/tinymce: affected < 5.10.0; fixed in 5.10.0
- npm tinymce: affected < 5.10.0; fixed in 5.10.0

## Suggested inspection (read-only)
- `python -m pip show django-tinymce`: prints the installed version. Run with the environment that serves production active.
- NuGet tinymce: check the installed version with your package manager.
- Packagist tinymce/tinymce: check the installed version with your package manager.
- `npm ls tinymce --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on django-tinymce, tinymce, tinymce/tinymce.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-r8hm-w5f7-wj39 (OSV record GHSA-r8hm-w5f7-wj39 lists affected ranges: npm tinymce >=0 =0 =0 =0 <3.4.0 (fixed))
- Verified: https://github.com/advisories/GHSA-r8hm-w5f7-wj39 (GitHub-reviewed advisory GHSA-r8hm-w5f7-wj39 lists affected ranges: npm tinymce >=0 =0 =0 =0 <3.4.0)

Commands are suggestions: review each one before running it.

Loading voting…