Cross-site scripting vulnerability in TinyMCE
CVE-2024-21908GHSA-5h9g-x5rv-25wg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tinymce 5.9.0; tinymce/tinymce 5.9.0; tinymce 5.9.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet tinymce
- Affected
- < 5.9.0
- Fixed in
- 5.9.0
Packagist tinymce/tinymce
- Affected
- < 5.9.0
- Fixed in
- 5.9.0
npm tinymce
- Affected
- < 5.9.0
- Fixed in
- 5.9.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5h9g-x5rv-25wg lists affected ranges: npm tinymce >=0 =0 =0 <5.9.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5h9g-x5rv-25wg lists affected ranges: npm tinymce >=0 =0 =0 <5.9.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2024-21908: 1.07% estimated exploitation activity in the next 30 days; percentile 64.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A cross-site scripting (XSS) vulnerability was discovered in the schema validation logic of the core parser. The vulnerability allowed arbitrary JavaScript execution when inserting a specially crafted piece of content into the editor using the clipboard or editor APIs. This malicious content could then end up in content published outside the editor, if no server-side sanitization was performed. This impacts all users who are using TinyMCE 5.8.2 or lower. Patches This vulnerability has been patched in TinyMCE 5.9.0 by ensuring schema validation was still performed after unwrapping invalid elements. Workarounds To work around this vulnerability, either: - Upgrade to TinyMCE 5.9.0 or higher - Manually sanitize the content using the BeforeSetContent event (see below) Example: Manually sanitize content Acknowledgements Tiny Technologies would like to thank William Bowling for discovering this vulnerability. References…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-5h9g-x5rv-25wg
- Revision 1 · created ·
Published from osv record GHSA-5h9g-x5rv-25wg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-21908 Advisory: Cross-site scripting vulnerability in TinyMCE IDs: CVE-2024-21908, GHSA-5h9g-x5rv-25wg Record: https://patchnext.com/advisories/cve-2024-21908 (revision 2, source checked 26 Oct 2026, 12:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tinymce 5.9.0; tinymce/tinymce 5.9.0; tinymce 5.9.0. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet tinymce: affected < 5.9.0; fixed in 5.9.0 - Packagist tinymce/tinymce: affected < 5.9.0; fixed in 5.9.0 - npm tinymce: affected < 5.9.0; fixed in 5.9.0 ## Suggested inspection (read-only) - NuGet tinymce: check the installed version with your package manager. - Packagist tinymce/tinymce: check the installed version with your package manager. - `npm ls tinymce --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tinymce, tinymce/tinymce. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5h9g-x5rv-25wg (OSV record GHSA-5h9g-x5rv-25wg lists affected ranges: npm tinymce >=0 =0 =0 <5.9.0 (fixed)) - Verified: https://github.com/advisories/GHSA-5h9g-x5rv-25wg (GitHub-reviewed advisory GHSA-5h9g-x5rv-25wg lists affected ranges: npm tinymce >=0 =0 =0 <5.9.0) Commands are suggestions: review each one before running it.
Loading voting…