Skip to content

← Actionable
Low, CVSS 3.4amended

Cross site scripting in zenml

CVE-2024-2171GHSA-vwgf-7f9h-h499

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (zenml 0.56.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI zenml

    Affected
    < 0.56.2
    Fixed in
    0.56.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.4 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:N/A:N
EPSS
  • CVE-2024-2171: 0.37% estimated exploitation activity in the next 30 days; percentile 30.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A stored Cross-Site Scripting (XSS) vulnerability was identified in the zenml-io/zenml repository, specifically within the 'logourl' field. By injecting malicious payloads into this field, an attacker could send harmful messages to other users, potentially compromising their accounts. The vulnerability affects version 0.55.3 and was fixed in version 0.56.2. The impact of exploiting this vulnerability could lead to user account compromise.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vwgf-7f9h-h499

  2. Revision 1 · created ·

    Published from osv record GHSA-vwgf-7f9h-h499

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-2171

Advisory: Cross site scripting in zenml
IDs: CVE-2024-2171, GHSA-vwgf-7f9h-h499
Record: https://patchnext.com/advisories/cve-2024-2171 (revision 2, source checked 26 Oct 2026, 13:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: zenml 0.56.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI zenml: affected < 0.56.2; fixed in 0.56.2

## Suggested inspection (read-only)
- `python -m pip show zenml`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on zenml.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vwgf-7f9h-h499 (OSV record GHSA-vwgf-7f9h-h499 lists affected ranges: PyPI zenml >=0 <0.56.2 (fixed))
- Verified: https://github.com/advisories/GHSA-vwgf-7f9h-h499 (GitHub-reviewed advisory GHSA-vwgf-7f9h-h499 lists affected ranges: PyPI zenml >=0 <0.56.2)

Commands are suggestions: review each one before running it.

Loading voting…