vantage6 vulnerable to username timing attack
CVE-2024-21671GHSA-45gq-q4xh-cp53
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vantage6 4.2.0; vantage6-server 4.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI vantage6
- Affected
- < 4.2.0
- Fixed in
- 4.2.0
PyPI vantage6-server
- Affected
- < 4.2.0
- Fixed in
- 4.2.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-45gq-q4xh-cp53 lists affected ranges: PyPI vantage6-server >=0 <4.2.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2024-31 lists affected ranges: PyPI vantage6 >=0 <4.2.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-45gq-q4xh-cp53 lists affected ranges: PyPI vantage6-server >=0 <4.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2024-21671: 0.40% estimated exploitation activity in the next 30 days; percentile 34.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact It is possible to find out usernames from the response time of login requests. This could aid attackers in credential attacks Workarounds No
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-45gq-q4xh-cp53
- Revision 2 · amended ·
Amended from osv record PYSEC-2024-31
- Revision 1 · created ·
Published from osv record GHSA-45gq-q4xh-cp53
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-21671 Advisory: vantage6 vulnerable to username timing attack IDs: CVE-2024-21671, GHSA-45gq-q4xh-cp53 Record: https://patchnext.com/advisories/cve-2024-21671 (revision 3, source checked 26 Oct 2026, 13:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vantage6 4.2.0; vantage6-server 4.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI vantage6: affected < 4.2.0; fixed in 4.2.0 - PyPI vantage6-server: affected < 4.2.0; fixed in 4.2.0 ## Suggested inspection (read-only) - `python -m pip show vantage6`: prints the installed version. Run with the environment that serves production active. - `python -m pip show vantage6-server`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vantage6, vantage6-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-45gq-q4xh-cp53 (OSV record GHSA-45gq-q4xh-cp53 lists affected ranges: PyPI vantage6-server >=0 <4.2.0 (fixed)) - Verified: https://osv.dev/vulnerability/PYSEC-2024-31 (OSV record PYSEC-2024-31 lists affected ranges: PyPI vantage6 >=0 <4.2.0 (fixed)) - Verified: https://github.com/advisories/GHSA-45gq-q4xh-cp53 (GitHub-reviewed advisory GHSA-45gq-q4xh-cp53 lists affected ranges: PyPI vantage6-server >=0 <4.2.0) Commands are suggestions: review each one before running it.
Loading voting…