Skip to content

← Actionable
Critical, CVSS 9.9amended

Hyperledger Aries Cloud Agent Python result of presentation verification not checked for LDP-VC

CVE-2024-21669GHSA-97x9-59rv-q5pm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (aries-cloudagent 0.11.0, 0.10.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI aries-cloudagent

    Affected
    >= 0.7.0, < 0.10.5>= 0.11.0rc1, < 0.11.0
    Fixed in
    0.10.5, 0.11.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:L
EPSS
  • CVE-2024-21669: 0.63% estimated exploitation activity in the next 30 days; percentile 50.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When verifying W3C Format Verifiable Credentials using JSON-LD with Linked Data Proofs (LDP-VCs), the result of verifying the presentation `document.proof` was not factored into the final `verified` value (`true`/`false`) on the presentation record. Below is an example result from verifying a JSON-LD Presentation where there is an error noted in the processing (mismatched challenge), but the overall result is incorrectly `"verified": true`: ```json { "verified": true, "presentation_result": { "verified": false, "document": { "@context": [ "https://www.w3.org/2018/credentials/v1" ], "type": [ "VerifiablePresentation" ], "verifiableCredential": [ { "@context": [ "https://www.w3.org/2018/credentials/v1", "https://w3id.org/citizenship/v1" ], "type": [ "VerifiableCredential", "PermanentResident" ], "issuer": "did:sov:EzcfrVw7Tveho5NjrmDWnd", "issuanceDate": "2023-11-18", "credentialSubject": { "type": [ "PermanentResident" ], "id":…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from osv record GHSA-97x9-59rv-q5pm

  2. Revision 3 · amended ·

    Amended from ghsa record GHSA-97x9-59rv-q5pm

  3. Revision 2 · amended ·

    Amended from ghsa record GHSA-97x9-59rv-q5pm

  4. Revision 1 · created ·

    Published from osv record GHSA-97x9-59rv-q5pm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-21669

Advisory: Hyperledger Aries Cloud Agent Python result of presentation verification not checked for LDP-VC
IDs: CVE-2024-21669, GHSA-97x9-59rv-q5pm
Record: https://patchnext.com/advisories/cve-2024-21669 (revision 4, source checked 28 Oct 2026, 06:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: aries-cloudagent 0.11.0, 0.10.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI aries-cloudagent: affected >= 0.7.0, < 0.10.5; >= 0.11.0rc1, < 0.11.0; fixed in 0.10.5, 0.11.0

## Suggested inspection (read-only)
- `python -m pip show aries-cloudagent`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on aries-cloudagent.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-97x9-59rv-q5pm (OSV record GHSA-97x9-59rv-q5pm lists affected ranges: PyPI aries-cloudagent >=0.7.0 =0.11.0rc1 <0.11.0 (fixed))
- Verified: https://github.com/advisories/GHSA-97x9-59rv-q5pm (GitHub-reviewed advisory GHSA-97x9-59rv-q5pm lists affected ranges: PyPI aries-cloudagent >=0.7.0 =0.11.0rc1 <0.11.0)

Commands are suggestions: review each one before running it.

Loading voting…