Skip to content

← Actionable
Medium, CVSS 6.5amended

vantage6 has insecure SSH configuration for node and server containers

CVE-2024-21653GHSA-2wgc-48g2-cj5w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vantage6-node 4.2.0; vantage6 4.2.0; vantage6-server 4.2.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2024-21653: 0.47% estimated exploitation activity in the next 30 days; percentile 40.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Nodes and servers get a ssh config by default that permits root login with password authentication. In a proper deployment, the SSH service is not exposed so there is no risk, but not all deployments are ideal. The default should therefore be less permissive. We will probably opt to completely remove the ssh option as it is only used for debugging. Later, we can add a debug mode where we can activate it if necessary. Workarounds Remove the ssh part from the docker file and build your own docker image

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-2wgc-48g2-cj5w

  2. Revision 3 · amended ·

    Amended from osv record PYSEC-2024-34

  3. Revision 2 · amended ·

    Amended from osv record PYSEC-2024-33

  4. Revision 1 · created ·

    Published from osv record GHSA-2wgc-48g2-cj5w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-21653

Advisory: vantage6 has insecure SSH configuration for node and server containers
IDs: CVE-2024-21653, GHSA-2wgc-48g2-cj5w
Record: https://patchnext.com/advisories/cve-2024-21653 (revision 4, source checked 26 Oct 2026, 13:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vantage6-node 4.2.0; vantage6 4.2.0; vantage6-server 4.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI vantage6-node: affected < 4.2.0; fixed in 4.2.0
- PyPI vantage6: affected < 4.2.0; fixed in 4.2.0
- PyPI vantage6-server: affected < 4.2.0; fixed in 4.2.0

## Suggested inspection (read-only)
- `python -m pip show vantage6-node`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show vantage6`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show vantage6-server`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vantage6-node, vantage6, vantage6-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2wgc-48g2-cj5w (OSV record GHSA-2wgc-48g2-cj5w lists affected ranges: PyPI vantage6 >=0 <4.2.0 (fixed))
- Verified: https://osv.dev/vulnerability/PYSEC-2024-33 (OSV record PYSEC-2024-33 lists affected ranges: PyPI vantage6-node >=0 <4.2.0 (fixed))
- Verified: https://osv.dev/vulnerability/PYSEC-2024-34 (OSV record PYSEC-2024-34 lists affected ranges: PyPI vantage6-server >=0 <4.2.0 (fixed))
- Verified: https://github.com/advisories/GHSA-2wgc-48g2-cj5w (GitHub-reviewed advisory GHSA-2wgc-48g2-cj5w lists affected ranges: PyPI vantage6 >=0 <4.2.0)

Commands are suggestions: review each one before running it.

Loading voting…