Skip to content

← Actionable
High, CVSS 7.5

XWiki vulnerable to Denial of Service attack through attachments

CVE-2024-21651GHSA-8959-rfxh-r4j4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-distribution-war 15.8-rc-1, 15.5.3, 14.10.18), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-8959-rfxh-r4j4 lists affected ranges: Maven org.xwiki.platform:xwiki-platform-distribution-war >=14.10 =15.0-rc-1 =15.6-rc-1 <15.8-rc-1

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2024-21651: 0.64% estimated exploitation activity in the next 30 days; percentile 50.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A user able to attach a file to a page can post a malformed TAR file by manipulating file modification times headers, which when parsed by Tika, could cause a denial of service issue via CPU consumption. Patches This vulnerability has been patched in XWiki 14.10.18, 15.5.3 and 15.8 RC1. Workarounds The workaround is to download commons-compress 1.24 and replace the one located in XWiki WEB-INF/lib/ folder. References https://jira.xwiki.org/browse/XCOMMONS-2796 For more information If you have any questions or comments about this advisory: Open an issue in Jira XWiki.org Email us at Security Mailing List

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-8959-rfxh-r4j4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-21651

Advisory: XWiki vulnerable to Denial of Service attack through attachments
IDs: CVE-2024-21651, GHSA-8959-rfxh-r4j4
Record: https://patchnext.com/advisories/cve-2024-21651 (revision 1, source checked 26 Oct 2026, 16:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-distribution-war 15.8-rc-1, 15.5.3, 14.10.18. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.xwiki.platform:xwiki-platform-distribution-war: affected >= 14.10, < 14.10.18; >= 15.0-rc-1, < 15.5.3; >= 15.6-rc-1, < 15.8-rc-1; fixed in 15.8-rc-1, 15.5.3, 14.10.18

## Suggested inspection (read-only)
- Maven org.xwiki.platform:xwiki-platform-distribution-war: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.xwiki.platform:xwiki-platform-distribution-war.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8959-rfxh-r4j4 (GitHub-reviewed advisory GHSA-8959-rfxh-r4j4 lists affected ranges: Maven org.xwiki.platform:xwiki-platform-distribution-war >=14.10 =15.0-rc-1 =15.6-rc-1 <15.8-rc-1)

Commands are suggestions: review each one before running it.

Loading voting…