Skip to content

← Actionable
Critical, CVSS 10.0

XWiki Remote Code Execution Vulnerability via User Registration

CVE-2024-21650GHSA-rj7p-xjv7-7229

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-administration-ui 15.8-rc-1, 15.5.3, 14.10.17), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-rj7p-xjv7-7229 lists affected ranges: Maven org.xwiki.platform:xwiki-platform-administration-ui >=2.2 =15.0-rc-1 =15.6-rc-1 <15.8-rc-1

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2024-21650: 93.48% estimated exploitation activity in the next 30 days; percentile 99.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact XWiki is vulnerable to a remote code execution (RCE) attack through its user registration feature. This issue allows an attacker to execute arbitrary code by crafting malicious payloads in the "first name" or "last name" fields during user registration. This impacts all installations that have user registration enabled for guests. To reproduce, register with any username and password and the following payload as "first name": ]]{{/html}}{{async}}{{groovy}}services.logging.getLogger("attacker").error("Attack succeeded){{/groovy}}{{/async}}. In the following page that confirms the success of the registration, the full first name should be displayed, linking to the created user. If the formatting is broken and a log message with content "ERROR attacker - Attack succeeded!" is logged, the attack succeeded. Patches This vulnerability has been patched in XWiki 14.10.17, 15.5.3 and 15.8 RC1. Workarounds In the administration of your wiki, under "Users & Rights" "Registration" set the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-rj7p-xjv7-7229

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-21650

Advisory: XWiki Remote Code Execution Vulnerability via User Registration
IDs: CVE-2024-21650, GHSA-rj7p-xjv7-7229
Record: https://patchnext.com/advisories/cve-2024-21650 (revision 1, source checked 26 Oct 2026, 16:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-administration-ui 15.8-rc-1, 15.5.3, 14.10.17. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.xwiki.platform:xwiki-platform-administration-ui: affected >= 2.2, < 14.10.17; >= 15.0-rc-1, < 15.5.3; >= 15.6-rc-1, < 15.8-rc-1; fixed in 14.10.17, 15.8-rc-1, 15.5.3

## Suggested inspection (read-only)
- Maven org.xwiki.platform:xwiki-platform-administration-ui: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.xwiki.platform:xwiki-platform-administration-ui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rj7p-xjv7-7229 (GitHub-reviewed advisory GHSA-rj7p-xjv7-7229 lists affected ranges: Maven org.xwiki.platform:xwiki-platform-administration-ui >=2.2 =15.0-rc-1 =15.6-rc-1 <15.8-rc-1)

Commands are suggestions: review each one before running it.

Loading voting…