Skip to content

← Actionable
Medium, CVSS 5.3amended

pyload Log Injection vulnerability

CVE-2024-21645GHSA-ghmw-rwh8-6qmr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pyload-ng 0.5.0b3.dev77), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pyload-ng

    Affected
    < 0.5.0b3.dev77
    Fixed in
    0.5.0b3.dev77

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2024-21645: 24.70% estimated exploitation activity in the next 30 days; percentile 97.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A log injection vulnerability was identified in pyload. This vulnerability allows any unauthenticated actor to inject arbitrary messages into the logs gathered by pyload. Details pyload will generate a log entry when attempting to sign in with faulty credentials. This entry will be in the form of Login failed for user 'USERNAME'. However, when supplied with a username containing a newline, this newline is not properly escaped. Newlines are also the delimiter between log entries. This allows the attacker to inject new log entries into the log file. PoC Run pyload in the default configuration by running the following command We can now sign in as the pyload user and view the logs at http://localhost:8000/logs. Any unauthenticated attacker can now make the following request to inject arbitrary logs. If we now were to look at the logs again, we see that the entry has successfully been injected. Impact Forged or otherwise, corrupted log files can be used to cover an attacker’s…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-ghmw-rwh8-6qmr

  2. Revision 1 · created ·

    Published from osv record GHSA-ghmw-rwh8-6qmr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-21645

Advisory: pyload Log Injection vulnerability
IDs: CVE-2024-21645, GHSA-ghmw-rwh8-6qmr
Record: https://patchnext.com/advisories/cve-2024-21645 (revision 2, source checked 26 Oct 2026, 13:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pyload-ng 0.5.0b3.dev77. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pyload-ng: affected < 0.5.0b3.dev77; fixed in 0.5.0b3.dev77

## Suggested inspection (read-only)
- `python -m pip show pyload-ng`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pyload-ng.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-ghmw-rwh8-6qmr (OSV record GHSA-ghmw-rwh8-6qmr lists affected ranges: PyPI pyload-ng >=0 <0.5.0b3.dev77 (fixed))
- Verified: https://github.com/advisories/GHSA-ghmw-rwh8-6qmr (GitHub-reviewed advisory GHSA-ghmw-rwh8-6qmr lists affected ranges: PyPI pyload-ng >=0 <0.5.0b3.dev77)

Commands are suggestions: review each one before running it.

Loading voting…