Skip to content

← Actionable
High, CVSS 7.5amended

pyload Unauthenticated Flask Configuration Leakage vulnerability

CVE-2024-21644GHSA-mqpq-2p68-46fv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pyload-ng 0.5.0b3.dev77), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pyload-ng

    Affected
    < 0.5.0b3.dev77
    Fixed in
    0.5.0b3.dev77

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2024-21644: 42.44% estimated exploitation activity in the next 30 days; percentile 98.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Any unauthenticated user can browse to a specific URL to expose the Flask config, including the SECRETKEY variable. Details Any unauthenticated user can browse to a specific URL to expose the Flask config, including the SECRETKEY variable. PoC Run pyload in the default configuration by running the following command Now browse to http://localhost:8000/render/info.html. Notice how the Flask configuration gets displayed. I was quite amused by this finding. I think it's a very interesting coming together of things that is so unlikely to happen. Below I will detail my process a bit more. I was looking through the code to see how the authorization mechanism is implemented when I spotted this route, which can be accessed by any unauthenticated actor - https://github.com/pyload/pyload/blob/57d81930edb59177c60830ad8ac36a91d0ec4c4e/src/pyload/webui/app/blueprints/appblueprint.py#L33C1-L37C51 This route allows me to load in any of the predefined templates. However, these templates will…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mqpq-2p68-46fv

  2. Revision 1 · created ·

    Published from osv record GHSA-mqpq-2p68-46fv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-21644

Advisory: pyload Unauthenticated Flask Configuration Leakage vulnerability
IDs: CVE-2024-21644, GHSA-mqpq-2p68-46fv
Record: https://patchnext.com/advisories/cve-2024-21644 (revision 2, source checked 26 Oct 2026, 13:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pyload-ng 0.5.0b3.dev77. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pyload-ng: affected < 0.5.0b3.dev77; fixed in 0.5.0b3.dev77

## Suggested inspection (read-only)
- `python -m pip show pyload-ng`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pyload-ng.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mqpq-2p68-46fv (OSV record GHSA-mqpq-2p68-46fv lists affected ranges: PyPI pyload-ng >=0 <0.5.0b3.dev77 (fixed))
- Verified: https://github.com/advisories/GHSA-mqpq-2p68-46fv (GitHub-reviewed advisory GHSA-mqpq-2p68-46fv lists affected ranges: PyPI pyload-ng >=0 <0.5.0b3.dev77)

Commands are suggestions: review each one before running it.

Loading voting…