D-Tale server-side request forgery through Web uploads
CVE-2024-21642GHSA-7hfx-h3j3-rwq4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (dtale 3.9.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI dtale
- Affected
- < 3.9.0
- Fixed in
- 3.9.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7hfx-h3j3-rwq4 lists affected ranges: PyPI dtale >=0 <3.9.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7hfx-h3j3-rwq4 lists affected ranges: PyPI dtale >=0 <3.9.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2024-21642: 0.71% estimated exploitation activity in the next 30 days; percentile 53.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Users hosting D-Tale publicly can be vulnerable to server-side request forgery (SSRF) allowing attackers to access files on the server. Patches Users should upgrade to version 3.9.0 where the "Load From the Web" input is turned off by default. You can find out more information on how to turn it back on here Workarounds The only workaround for versions earlier than 3.9.0 is to only host D-Tale to trusted users. References See "Load Data & Sample Datasets" documentation
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7hfx-h3j3-rwq4
- Revision 1 · created ·
Published from osv record GHSA-7hfx-h3j3-rwq4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-21642 Advisory: D-Tale server-side request forgery through Web uploads IDs: CVE-2024-21642, GHSA-7hfx-h3j3-rwq4 Record: https://patchnext.com/advisories/cve-2024-21642 (revision 2, source checked 26 Oct 2026, 13:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: dtale 3.9.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI dtale: affected < 3.9.0; fixed in 3.9.0 ## Suggested inspection (read-only) - `python -m pip show dtale`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on dtale. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7hfx-h3j3-rwq4 (OSV record GHSA-7hfx-h3j3-rwq4 lists affected ranges: PyPI dtale >=0 <3.9.0 (fixed)) - Verified: https://github.com/advisories/GHSA-7hfx-h3j3-rwq4 (GitHub-reviewed advisory GHSA-7hfx-h3j3-rwq4 lists affected ranges: PyPI dtale >=0 <3.9.0) Commands are suggestions: review each one before running it.
Loading voting…