Skip to content

← Actionable
Medium, CVSS 6.1

view_component Cross-site Scripting vulnerability

CVE-2024-21636GHSA-wf2x-8w6j-qw37

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (view_component 3.9.0, 2.83.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems view_component

    Affected
    >= 3.0.0, < 3.9.0< 2.83.0
    Fixed in
    3.9.0, 2.83.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2024-21636: 0.50% estimated exploitation activity in the next 30 days; percentile 42.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact What kind of vulnerability is it? Who is impacted? This is an XSS vulnerability that has the potential to impact anyone rendering a component directly from a controller with the viewcomponent gem. Note that only components that define a #call method (i.e. instead of using a sidecar template) are affected. The return value of the #call method is not sanitized and can include user-defined content. In addition, the return value of the #outputpostamble method is not sanitized, which can also lead to XSS issues. Patches Has the problem been patched? What versions should users upgrade to? Versions 3.9.0 has been released and fully mitigates both the #call and the #outputpostamble vulnerabilities. Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? Sanitize the return value of #call, eg: References Are there any links users can visit to find out more? https://github.com/ViewComponent/viewcomponent/pull/1950 For more information If you have…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wf2x-8w6j-qw37

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-21636

Advisory: view_component Cross-site Scripting vulnerability
IDs: CVE-2024-21636, GHSA-wf2x-8w6j-qw37
Record: https://patchnext.com/advisories/cve-2024-21636 (revision 1, source checked 26 Oct 2026, 15:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: view_component 3.9.0, 2.83.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems view_component: affected >= 3.0.0, < 3.9.0; < 2.83.0; fixed in 3.9.0, 2.83.0

## Suggested inspection (read-only)
- RubyGems view_component: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on view_component.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wf2x-8w6j-qw37 (GitHub-reviewed advisory GHSA-wf2x-8w6j-qw37 lists affected ranges: RubyGems view_component >=3.0.0 =0 <2.83.0)

Commands are suggestions: review each one before running it.

Loading voting…