Omniauth::MicrosoftGraph Account takeover (nOAuth)
CVE-2024-21632GHSA-5g66-628f-7cvj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (omniauth-microsoft_graph 2.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems omniauth-microsoft_graph
- Affected
- < 2.0.0
- Fixed in
- 2.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5g66-628f-7cvj lists affected ranges: RubyGems omniauth-microsoft_graph >=0 <2.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L
- EPSS
- CVE-2024-21632: 0.90% estimated exploitation activity in the next 30 days; percentile 59.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The implementation did not validate the legitimacy of the email attribute of the user nor did it give/document an option to do so, making it susceptible to nOAuth misconfiguration in cases when the email is used as a trusted user identifier
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5g66-628f-7cvj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-21632 Advisory: Omniauth::MicrosoftGraph Account takeover (nOAuth) IDs: CVE-2024-21632, GHSA-5g66-628f-7cvj Record: https://patchnext.com/advisories/cve-2024-21632 (revision 1, source checked 26 Oct 2026, 15:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: omniauth-microsoft_graph 2.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems omniauth-microsoft_graph: affected < 2.0.0; fixed in 2.0.0 ## Suggested inspection (read-only) - RubyGems omniauth-microsoft_graph: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on omniauth-microsoft_graph. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5g66-628f-7cvj (GitHub-reviewed advisory GHSA-5g66-628f-7cvj lists affected ranges: RubyGems omniauth-microsoft_graph >=0 <2.0.0) Commands are suggestions: review each one before running it.
Loading voting…