Skip to content

← Actionable
Medium, CVSS 5.7amended

NoneBot Potential Information Leak in User-Constructed Message Templates

CVE-2024-21624GHSA-59j8-776v-xxxg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nonebot2 2.2.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI nonebot2

    Affected
    >= 2.0.0a16, <= 2.1.3
    Fixed in
    2.2.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N
EPSS
  • CVE-2024-21624: 0.49% estimated exploitation activity in the next 30 days; percentile 42.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact This security advisory pertains to a potential information leak (e.g., environment variables) in instances where developers utilize MessageTemplate and incorporate user-provided data into templates. Patches The identified vulnerability has been remedied in fix #2509 and will be included in versions released after 2.1.3. Users are strongly advised to upgrade to these patched versions to safeguard against the vulnerability. Workarounds A temporary workaround involves filtering underscores before incorporating user input into the message template. References - Pull Request #2509 - CWE-1336

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-59j8-776v-xxxg

  2. Revision 1 · created ·

    Published from osv record GHSA-59j8-776v-xxxg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-21624

Advisory: NoneBot Potential Information Leak in User-Constructed Message Templates
IDs: CVE-2024-21624, GHSA-59j8-776v-xxxg
Record: https://patchnext.com/advisories/cve-2024-21624 (revision 2, source checked 26 Oct 2026, 13:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nonebot2 2.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI nonebot2: affected >= 2.0.0a16, <= 2.1.3; fixed in 2.2.0

## Suggested inspection (read-only)
- `python -m pip show nonebot2`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nonebot2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-59j8-776v-xxxg (OSV record GHSA-59j8-776v-xxxg lists affected ranges: PyPI nonebot2 >=2.0.0a16 <2.2.0 (fixed))
- Verified: https://github.com/advisories/GHSA-59j8-776v-xxxg (GitHub-reviewed advisory GHSA-59j8-776v-xxxg lists affected ranges: PyPI nonebot2 >=2.0.0a16 <=2.1.3)

Commands are suggestions: review each one before running it.

Loading voting…