Browsershot Local File Inclusion
CVE-2024-21544GHSA-g2r4-phv7-5fgv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (spatie/browsershot 5.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist spatie/browsershot
- Affected
- < 5.0.1
- Fixed in
- 5.0.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g2r4-phv7-5fgv lists affected ranges: Packagist spatie/browsershot >=0 <5.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2024-21544: 0.57% estimated exploitation activity in the next 30 days; percentile 47.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of the package spatie/browsershot before 5.0.1 are vulnerable to Improper Input Validation due to improper URL validation through the setUrl method. An attacker can exploit this vulnerability by using leading whitespace (%20) before the file:// protocol, resulting in Local File Inclusion, which allows the attacker to read sensitive files on the server.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-g2r4-phv7-5fgv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-21544 Advisory: Browsershot Local File Inclusion IDs: CVE-2024-21544, GHSA-g2r4-phv7-5fgv Record: https://patchnext.com/advisories/cve-2024-21544 (revision 1, source checked 26 Oct 2026, 14:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: spatie/browsershot 5.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist spatie/browsershot: affected < 5.0.1; fixed in 5.0.1 ## Suggested inspection (read-only) - Packagist spatie/browsershot: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on spatie/browsershot. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-g2r4-phv7-5fgv (GitHub-reviewed advisory GHSA-g2r4-phv7-5fgv lists affected ranges: Packagist spatie/browsershot >=0 <5.0.1) Commands are suggestions: review each one before running it.
Loading voting…