Skip to content

← Actionable
Medium, CVSS 4.5

Sequential calls of encryption API (encrypt, wrap, and dump) result in nonce reuse

CVE-2024-21530GHSA-6878-6wc2-pf5h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (cocoon 0.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io cocoon

    Affected
    < 0.4.0
    Fixed in
    0.4.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.5 · CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N
EPSS
  • CVE-2024-21530: 0.14% estimated exploitation activity in the next 30 days; percentile 3.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Problem: Trying to create a new encrypted message with the same cocoon object generates the same ciphertext. It mostly affects MiniCocoon and Cocoon objects with custom seeds and RNGs (where StdRng is used under the hood). Note: The issue does NOT affect objects created with Cocoon::new which utilizes ThreadRng. Cause: StdRng produces the same nonce because StdRng::clone resets its state. Measure: Make encryption API mutable (encrypt, wrap, and dump). Workaround: Create a new cocoon object with a new seed per each encryption. How to Reproduce Workaround For cocoon <= 0.3.3, create a new cocoon with a different seed per each encrypt/wrap/dump call.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6878-6wc2-pf5h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-21530

Advisory: Sequential calls of encryption API (`encrypt`, `wrap`, and `dump`) result in nonce reuse
IDs: CVE-2024-21530, GHSA-6878-6wc2-pf5h
Record: https://patchnext.com/advisories/cve-2024-21530 (revision 1, source checked 26 Oct 2026, 15:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: cocoon 0.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io cocoon: affected < 0.4.0; fixed in 0.4.0

## Suggested inspection (read-only)
- crates.io cocoon: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on cocoon.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6878-6wc2-pf5h (GitHub-reviewed advisory GHSA-6878-6wc2-pf5h lists affected ranges: crates.io cocoon >=0 <0.4.0)

Commands are suggestions: review each one before running it.

Loading voting…