Sinatra vulnerable to Reliance on Untrusted Inputs in a Security Decision
CVE-2024-21510GHSA-hxx2-7vcw-mqr3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sinatra 4.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems sinatra
- Affected
- < 4.1.0
- Fixed in
- 4.1.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hxx2-7vcw-mqr3 lists affected ranges: RubyGems sinatra >=0 <4.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-21510: 0.49% estimated exploitation activity in the next 30 days; percentile 42.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of the package sinatra from 0.0.0 are vulnerable to Reliance on Untrusted Inputs in a Security Decision via the X-Forwarded-Host (XFH) header. When making a request to a method with redirect applied, it is possible to trigger an Open Redirect Attack by inserting an arbitrary address into this header. If used for caching purposes, such as with servers like Nginx, or as a reverse proxy, without handling the X-Forwarded-Host header, attackers can potentially exploit Cache Poisoning or Routing-based SSRF.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hxx2-7vcw-mqr3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-21510 Advisory: Sinatra vulnerable to Reliance on Untrusted Inputs in a Security Decision IDs: CVE-2024-21510, GHSA-hxx2-7vcw-mqr3 Record: https://patchnext.com/advisories/cve-2024-21510 (revision 1, source checked 26 Oct 2026, 15:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sinatra 4.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems sinatra: affected < 4.1.0; fixed in 4.1.0 ## Suggested inspection (read-only) - RubyGems sinatra: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sinatra. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hxx2-7vcw-mqr3 (GitHub-reviewed advisory GHSA-hxx2-7vcw-mqr3 lists affected ranges: RubyGems sinatra >=0 <4.1.0) Commands are suggestions: review each one before running it.
Loading voting…