Skip to content

← Actionable
High, CVSS 7.5amended

web3-utils Prototype Pollution vulnerability

CVE-2024-21505GHSA-2g4c-8fpm-c46v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (web3-utils 4.2.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm web3-utils

    Affected
    >= 4.0.1, < 4.2.1
    Fixed in
    4.2.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2024-21505: 0.72% estimated exploitation activity in the next 30 days; percentile 53.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact: The mergeDeep() function in the web3-utils package has been identified for Prototype Pollution vulnerability. An attacker has the ability to modify an object's prototype, which could result in changing the behavior of all objects that inherit from the impacted prototype by providing carefully crafted input to function. Patches: It has been fixed in web3-utils version 4.2.1 so all packages and apps depending on web3-utils =4.0.1 and <=4.2.0 should upgrade to web3-utils 4.2.1. Workarounds: None

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2g4c-8fpm-c46v

  2. Revision 1 · created ·

    Published from osv record GHSA-2g4c-8fpm-c46v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-21505

Advisory: web3-utils Prototype Pollution vulnerability
IDs: CVE-2024-21505, GHSA-2g4c-8fpm-c46v
Record: https://patchnext.com/advisories/cve-2024-21505 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: web3-utils 4.2.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm web3-utils: affected >= 4.0.1, < 4.2.1; fixed in 4.2.1

## Suggested inspection (read-only)
- `npm ls web3-utils --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on web3-utils.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2g4c-8fpm-c46v (OSV record GHSA-2g4c-8fpm-c46v lists affected ranges: npm web3-utils >=4.0.1 <4.2.1 (fixed))
- Verified: https://github.com/advisories/GHSA-2g4c-8fpm-c46v (GitHub-reviewed advisory GHSA-2g4c-8fpm-c46v lists affected ranges: npm web3-utils >=4.0.1 <4.2.1)

Commands are suggestions: review each one before running it.

Loading voting…