Dash apps vulnerable to Cross-site Scripting
CVE-2024-21485GHSA-547x-748v-vp6p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (dash-core-components 2.0.0; dash-core-components 2.13.0; dash 2.15.0, 2.13.0; dash-html-components 2.0.16; dash-html-components 2.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI dash-core-components
- Affected
- < 2.0.0
- Fixed in
- 2.0.0
- Affected
- < 2.13.0
- Fixed in
- 2.13.0
PyPI dash
- Affected
- < 2.13.0>= 2.14.0, < 2.15.0
- Fixed in
- 2.13.0, 2.15.0
- Affected
- < 2.0.16
- Fixed in
- 2.0.16
PyPI dash-html-components
- Affected
- < 2.0.0
- Fixed in
- 2.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-547x-748v-vp6p lists affected ranges: npm dash-core-components >=0 =0 =0 =0 =0 <2.0.16 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
Reviewed source-scoped correction: PyPI dash intervals preserved individually from PYSEC-2024-35; source disagreement requires review before replacing this projection.
VerifiedObserved Reviewed official source; package identities and intervals kept within source scope.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-547x-748v-vp6p lists affected ranges: npm dash-core-components >=0 =0 =0 =0 =0 <2.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 4.8 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:N/VI:N/VA:N/SC:H/SI:L/SA:N · score source
- EPSS
- CVE-2024-21485: 1.49% estimated exploitation activity in the next 30 days; percentile 74.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of the package dash-core-components before 2.13.0; versions of the package dash-core-components before 2.0.0; versions of the package dash before 2.15.0; versions of the package dash-html-components before 2.0.0; versions of the package dash-html-components before 2.0.16 are vulnerable to Cross-site Scripting (XSS) when the href of the a tag is controlled by an adversary. An authenticated attacker who stores a view that exploits this vulnerability could steal the data that's visible to another user who opens that view - not just the data already included on the page, but they could also, in theory, make additional requests and access other data accessible to this user. In some cases, they could also steal the access tokens of that user, which would allow the attacker to act as that user, including viewing other apps and resources hosted on the same server. Note: This is only exploitable in Dash apps that include some mechanism to store user input to be reloaded by a…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-547x-748v-vp6p
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-547x-748v-vp6p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-21485 Advisory: Dash apps vulnerable to Cross-site Scripting IDs: CVE-2024-21485, GHSA-547x-748v-vp6p Record: https://patchnext.com/advisories/cve-2024-21485 (revision 3, source checked 26 Oct 2026, 12:57 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: dash-core-components 2.0.0; dash-core-components 2.13.0; dash 2.15.0, 2.13.0; dash-html-components 2.0.16; dash-html-components 2.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI dash-core-components: affected < 2.0.0; fixed in 2.0.0 - npm dash-core-components: affected < 2.13.0; fixed in 2.13.0 - PyPI dash: affected < 2.13.0; >= 2.14.0, < 2.15.0; fixed in 2.13.0, 2.15.0 - npm dash-html-components: affected < 2.0.16; fixed in 2.0.16 - PyPI dash-html-components: affected < 2.0.0; fixed in 2.0.0 ## Suggested inspection (read-only) - `python -m pip show dash-core-components`: prints the installed version. Run with the environment that serves production active. - `npm ls dash-core-components --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `python -m pip show dash`: prints the installed version. Run with the environment that serves production active. - `npm ls dash-html-components --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `python -m pip show dash-html-components`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on dash-core-components, dash, dash-html-components. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-547x-748v-vp6p (OSV record GHSA-547x-748v-vp6p lists affected ranges: npm dash-core-components >=0 =0 =0 =0 =0 <2.0.16 (fixed)) - Verified: https://osv.dev/vulnerability/PYSEC-2024-35 (Reviewed source-scoped correction: PyPI dash intervals preserved individually from PYSEC-2024-35; source disagreement requires review before replacing this projection.) - Verified: https://github.com/advisories/GHSA-547x-748v-vp6p (GitHub-reviewed advisory GHSA-547x-748v-vp6p lists affected ranges: npm dash-core-components >=0 =0 =0 =0 =0 <2.0.0) Commands are suggestions: review each one before running it.
Loading voting…