Magento Open Source allows Cross-Site Scripting (XSS)
CVE-2024-20719GHSA-264g-f7v8-q5qq
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist magento/project-community-edition
- Affected
- <= 2.0.2
- Fixed in
- no fixed version recorded
Packagist magento/community-edition
- Affected
- >= 2.4.6, <= 2.4.6>= 2.4.5, <= 2.4.5>= 2.4.4, <= 2.4.4>= 2.4.6-p1, < 2.4.6-p4>= 2.4.5-p1, < 2.4.5-p6>= 2.4.4-p1, < 2.4.4-p7
- Fixed in
- 2.4.4-p7, 2.4.5-p6, 2.4.6-p4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-264g-f7v8-q5qq lists affected ranges: Packagist magento/community-edition >=2.4.6 =2.4.5 =2.4.4 =2.4.6-p1 =2.4.5-p1 =2.4.4-p1 =0 <=2.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:U · score source
- EPSS
- CVE-2024-20719: 1.31% estimated exploitation activity in the next 30 days; percentile 70.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Adobe Commerce versions 2.4.6-p3, 2.4.5-p5, 2.4.4-p6 and earlier are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by an admin attacker to inject malicious scripts into every admin page. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field, that could be leveraged to gain admin access.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-264g-f7v8-q5qq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-20719 Advisory: Magento Open Source allows Cross-Site Scripting (XSS) IDs: CVE-2024-20719, GHSA-264g-f7v8-q5qq Record: https://patchnext.com/advisories/cve-2024-20719 (revision 1, source checked 26 Oct 2026, 14:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: magento/community-edition 2.4.6-p4, 2.4.5-p6, 2.4.4-p7. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist magento/project-community-edition: affected <= 2.0.2 - Packagist magento/community-edition: affected >= 2.4.6, <= 2.4.6; >= 2.4.5, <= 2.4.5; >= 2.4.4, <= 2.4.4; >= 2.4.6-p1, < 2.4.6-p4; >= 2.4.5-p1, < 2.4.5-p6; >= 2.4.4-p1, < 2.4.4-p7; fixed in 2.4.4-p7, 2.4.5-p6, 2.4.6-p4 ## Suggested inspection (read-only) - Packagist magento/project-community-edition: check the installed version with your package manager. - Packagist magento/community-edition: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on magento/project-community-edition, magento/community-edition. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-264g-f7v8-q5qq (GitHub-reviewed advisory GHSA-264g-f7v8-q5qq lists affected ranges: Packagist magento/community-edition >=2.4.6 =2.4.5 =2.4.4 =2.4.6-p1 =2.4.5-p1 =2.4.4-p1 =0 <=2.0.2) Commands are suggestions: review each one before running it.
Loading voting…