Skip to content

← Actionable
Medium, CVSS 5.9amended

Scrapy leaks the authorization header on same-domain but cross-origin redirects

CVE-2024-1968GHSA-4qqq-9vqf-3h3f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (scrapy 2.11.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI scrapy

    Affected
    < 2.0.0>= 2.0.0, < 2.11.2
    Fixed in
    2.11.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2024-1968: 0.69% estimated exploitation activity in the next 30 days; percentile 52.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Since version 2.11.1, Scrapy drops the Authorization header when a request is redirected to a different domain. However, it keeps the header if the domain remains the same but the scheme (http/https) or the port change, all scenarios where the header should also be dropped. In the context of a man-in-the-middle attack, this could be used to get access to the value of that Authorization header Patches Upgrade to Scrapy 2.11.2. Workarounds There is no easy workaround for unpatched versions of Scrapy. You can replace the built-in redirect middlewares with custom ones patched for this issue, but you have to patch them yourself, manually. References This security issue was reported and fixed by @szarny at https://huntr.com/bounties/27f6a021-a891-446a-ada5-0226d619dd1a/.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-4qqq-9vqf-3h3f

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-4qqq-9vqf-3h3f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-1968

Advisory: Scrapy leaks the authorization header on same-domain but cross-origin redirects
IDs: CVE-2024-1968, GHSA-4qqq-9vqf-3h3f
Record: https://patchnext.com/advisories/cve-2024-1968 (revision 3, source checked 26 Oct 2026, 13:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: scrapy 2.11.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI scrapy: affected < 2.0.0; >= 2.0.0, < 2.11.2; fixed in 2.11.2

## Suggested inspection (read-only)
- `python -m pip show scrapy`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on scrapy.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4qqq-9vqf-3h3f (OSV record GHSA-4qqq-9vqf-3h3f lists affected ranges: PyPI scrapy >=0 <2.11.2 (fixed))
- Verified: https://osv.dev/vulnerability/PYSEC-2024-258 (Reviewed source-scoped correction: PyPI scrapy intervals preserved individually from PYSEC-2024-258; source disagreement requires review before replacing this projection.)
- Verified: https://github.com/advisories/GHSA-4qqq-9vqf-3h3f (GitHub-reviewed advisory GHSA-4qqq-9vqf-3h3f lists affected ranges: PyPI scrapy >=0 <2.11.2)

Commands are suggestions: review each one before running it.

Loading voting…