Gradio apps vulnerable to timing attacks to guess password
CVE-2024-1729GHSA-hmx6-r76c-85g9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (gradio 4.19.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI gradio
- Affected
- < 4.19.2
- Fixed in
- 4.19.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hmx6-r76c-85g9 lists affected ranges: PyPI gradio >=0 <4.19.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hmx6-r76c-85g9 lists affected ranges: PyPI gradio >=0 <4.19.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2024-1729: 0.50% estimated exploitation activity in the next 30 days; percentile 42.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact This security policy is with regards to a timing attack that allows users of Gradio apps to potentially guess the password of password-protected Gradio apps. This relies on the fact that string comparisons in Python terminate early, as soon as there is a string mismatch. Because Gradio apps are, by default, not rate-limited, a user could brute-force millions of guesses to figure out the correct username and password. Patches Yes, the problem has been patched in Gradio version 4.19.2 or higher. We have no knowledge of this exploit being used against users of Gradio applications, but we encourage all users to upgrade to Gradio 4.19.2 or higher. Fixed in: https://github.com/gradio-app/gradio/commit/e329f1fd38935213fe0e73962e8cbd5d3af6e87b
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-hmx6-r76c-85g9
- Revision 1 · created ·
Published from osv record GHSA-hmx6-r76c-85g9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-1729 Advisory: Gradio apps vulnerable to timing attacks to guess password IDs: CVE-2024-1729, GHSA-hmx6-r76c-85g9 Record: https://patchnext.com/advisories/cve-2024-1729 (revision 2, source checked 26 Oct 2026, 13:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: gradio 4.19.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI gradio: affected < 4.19.2; fixed in 4.19.2 ## Suggested inspection (read-only) - `python -m pip show gradio`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on gradio. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hmx6-r76c-85g9 (OSV record GHSA-hmx6-r76c-85g9 lists affected ranges: PyPI gradio >=0 <4.19.2 (fixed)) - Verified: https://github.com/advisories/GHSA-hmx6-r76c-85g9 (GitHub-reviewed advisory GHSA-hmx6-r76c-85g9 lists affected ranges: PyPI gradio >=0 <4.19.2) Commands are suggestions: review each one before running it.
Loading voting…