Skip to content

← Actionable
Medium, CVSS 4.3amended

Gradio applications running locally vulnerable to 3rd party websites accessing routes and uploading files

CVE-2024-1727GHSA-48cq-79qq-6f7x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (gradio 4.19.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI gradio

    Affected
    < 4.19.2
    Fixed in
    4.19.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
EPSS
  • CVE-2024-1727: 0.35% estimated exploitation activity in the next 30 days; percentile 28.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact This CVE covers the ability of 3rd party websites to access routes and upload files to users running Gradio applications locally. For example, the malicious owners of www.dontvisitme.com could put a script on their website that uploads a large file to http://localhost:7860/upload and anyone who visits their website and has a Gradio app will now have that large file uploaded on their computer Patches Yes, the problem has been patched in Gradio version 4.19.2 or higher. We have no knowledge of this exploit being used against users of Gradio applications, but we encourage all users to upgrade to Gradio 4.19.2 or higher. Fixed in: https://github.com/gradio-app/gradio/commit/84802ee6a4806c25287344dce581f9548a99834a CVE: https://nvd.nist.gov/vuln/detail/CVE-2024-1727

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-48cq-79qq-6f7x

  2. Revision 1 · created ·

    Published from osv record GHSA-48cq-79qq-6f7x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-1727

Advisory: Gradio applications running locally vulnerable to 3rd party websites accessing routes and uploading files
IDs: CVE-2024-1727, GHSA-48cq-79qq-6f7x
Record: https://patchnext.com/advisories/cve-2024-1727 (revision 2, source checked 26 Oct 2026, 13:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: gradio 4.19.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI gradio: affected < 4.19.2; fixed in 4.19.2

## Suggested inspection (read-only)
- `python -m pip show gradio`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on gradio.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-48cq-79qq-6f7x (OSV record GHSA-48cq-79qq-6f7x lists affected ranges: PyPI gradio >=0 <4.19.2 (fixed))
- Verified: https://github.com/advisories/GHSA-48cq-79qq-6f7x (GitHub-reviewed advisory GHSA-48cq-79qq-6f7x lists affected ranges: PyPI gradio >=0 <4.19.2)

Commands are suggestions: review each one before running it.

Loading voting…