Skip to content

← Actionable
Medium, CVSS 5.3amended

flask-cors vulnerable to log injection when the log level is set to debug

CVE-2024-1681GHSA-84pr-m4jr-85g5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flask-cors 4.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2024-1681: 0.58% estimated exploitation activity in the next 30 days; percentile 47.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

corydolphin/flask-cors is vulnerable to log injection when the log level is set to debug. An attacker can inject fake log entries into the log file by sending a specially crafted GET request containing a CRLF sequence in the request path. This vulnerability allows attackers to corrupt log files, potentially covering tracks of other attacks, confusing log post-processing tools, and forging log entries. The issue is due to improper output neutralization for logs.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-84pr-m4jr-85g5

  2. Revision 1 · created ·

    Published from osv record GHSA-84pr-m4jr-85g5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-1681

Advisory: flask-cors vulnerable to log injection when the log level is set to debug
IDs: CVE-2024-1681, GHSA-84pr-m4jr-85g5
Record: https://patchnext.com/advisories/cve-2024-1681 (revision 2, source checked 26 Oct 2026, 13:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flask-cors 4.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI flask-cors: affected <= 4.0.0; fixed in 4.0.1

## Suggested inspection (read-only)
- `python -m pip show flask-cors`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flask-cors.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-84pr-m4jr-85g5 (OSV record GHSA-84pr-m4jr-85g5 lists affected ranges: PyPI flask-cors >=0 <4.0.1 (fixed))
- Verified: https://github.com/advisories/GHSA-84pr-m4jr-85g5 (GitHub-reviewed advisory GHSA-84pr-m4jr-85g5 lists affected ranges: PyPI flask-cors >=0 <=4.0.0)

Commands are suggestions: review each one before running it.

Loading voting…