agent-js: Insecure Key Generation in Ed25519KeyIdentity.generate
CVE-2024-1631GHSA-c9vv-fhgv-cjc3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@dfinity/auth-client 1.0.1; @dfinity/identity 1.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 0.20.0-beta.0, < 1.0.1
- Fixed in
- 1.0.1
- Affected
- >= 0.20.0-beta.0, < 1.0.1
- Fixed in
- 1.0.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-c9vv-fhgv-cjc3 lists affected ranges: npm @dfinity/identity >=0.20.0-beta.0 =0.20.0-beta.0 <1.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c9vv-fhgv-cjc3 lists affected ranges: npm @dfinity/identity >=0.20.0-beta.0 =0.20.0-beta.0 <1.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2024-1631: 0.88% estimated exploitation activity in the next 30 days; percentile 59.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The library offers a function to generate an ed25519 key pair via Ed25519KeyIdentity.generate with an optional param to provide a 32 byte seed value, which will then be used as the secret key. When no seed value is provided, it is expected that the library generates the secret key using secure randomness. However, a recent change broke this guarantee and uses an insecure seed for key pair generation. Since the private key of this identity (535yc-uxytb-gfk7h-tny7p-vjkoe-i4krp-3qmcl-uqfgr-cpgej-yqtjq-rqe) is compromised, one could lose funds associated with the principal on ledgers or lose access to a canister where this principal is the controller. Users are asked to take proactive measures mentioned below in Workarounds:Users to protect their assets. Patches Patch for the vulnerability is available in v1.0.1 for all the packages listed in the advisory. Please upgrade and deploy your canisters immediately. Workarounds Developers The recommended fix is to upgrade the package to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-c9vv-fhgv-cjc3
- Revision 1 · created ·
Published from osv record GHSA-c9vv-fhgv-cjc3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-1631 Advisory: agent-js: Insecure Key Generation in `Ed25519KeyIdentity.generate` IDs: CVE-2024-1631, GHSA-c9vv-fhgv-cjc3 Record: https://patchnext.com/advisories/cve-2024-1631 (revision 2, source checked 26 Oct 2026, 12:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @dfinity/auth-client 1.0.1; @dfinity/identity 1.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @dfinity/auth-client: affected >= 0.20.0-beta.0, < 1.0.1; fixed in 1.0.1 - npm @dfinity/identity: affected >= 0.20.0-beta.0, < 1.0.1; fixed in 1.0.1 ## Suggested inspection (read-only) - `npm ls @dfinity/auth-client --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @dfinity/identity --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @dfinity/auth-client, @dfinity/identity. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-c9vv-fhgv-cjc3 (OSV record GHSA-c9vv-fhgv-cjc3 lists affected ranges: npm @dfinity/identity >=0.20.0-beta.0 =0.20.0-beta.0 <1.0.1 (fixed)) - Verified: https://github.com/advisories/GHSA-c9vv-fhgv-cjc3 (GitHub-reviewed advisory GHSA-c9vv-fhgv-cjc3 lists affected ranges: npm @dfinity/identity >=0.20.0-beta.0 =0.20.0-beta.0 <1.0.1) Commands are suggestions: review each one before running it.
Loading voting…